Ask Your Question
0

ROS groovy ROSARIA problem with rosmake

asked 2013-06-11 05:34:41 -0500

roman27 gravatar image

updated 2013-06-17 06:19:02 -0500

allenh1 gravatar image

Hi, we were using the tutorial to make our pioneer p3-dx to MOVE.
the tutorial could be found on the website of tugraz under the
query "Poineer_move" But on the Step4:(Once) we didn't get exacutable file rob_key and though our robot didn't move. We have Ubuntu 12.10 with ROS groovy installed. Are we on the right way? Are there other ways to send the robot velocity data and to make it move? Thank you.


The build log can be found here.


We have done the process you described, but unfortunately got this error. What is that package joy?

Failed to invoke /opt/ros/groovy/bin/rospack deps-manifests p2os_teleop [rospack] Error: package/stack 'p2os_teleop' depends on non-existent package 'joy' and rosdep claims that it is not a system dependency. Check the ROS_PACKAGE_PATH or try calling 'rosdep update'

CMake Error at /opt/ros/groovy/share/ros/core/rosbuild/public.cmake:129 (message):

Failed to invoke rospack to get compile flags for package 'p2os_teleop'.
Look above for errors from rospack itself.  Aborting.  Please fix the
broken dependency!
Call Stack (most recent call first): /opt/ros/groovy/share/ros/core/rosbuild/public.cmake:203 (rosbuild_invoke_rospack) CMakeLists.txt:12 (rosbuild_init)

-- Configuring incomplete, errors occurred!

We have tried the command you recommended, it gave such result.

rospc@rospc-LIFEBOOK-UH572:~/ros_ws/src$ sudo apt-get install ros-groovy-pr2-controllers Reading package lists... Done Building dependency tree 
Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: mobilesim:i386 : Depends: xfonts-100dpi:i386 but it is not installable ros-groovy-pr2-controllers : Depends: ros-groovy-control (= 1.1.6-0quantal-20130325-1823-+0000) but it is not going to be installed Depends: ros-groovy-orocos-kinematics-dynamics (= 0.2.3-s1364236848~quantal) but it is not going to be installed Depends: ros-groovy-pr2-common (= 1.10.3-s1364355959~quantal) but it is not going to be installed Depends: ros-groovy-pr2-mechanism (= 1.7.4-s1369206270~quantal) but it is not going to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Also we have installed joy package from here, and tried with it, but still got the same p2os_teleop error.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-06-11 08:30:35 -0500

allenh1 gravatar image

updated 2013-06-17 06:21:32 -0500

There are certainly other ways to make the pioneers move. You might consider the vanderbilt-p2os stack. It has been updated to be used with Groovy. We use it on the three pioneer robots at Vanderbilt.

The velocity can be sent to the p2os stack by publishing a geometry_msgs::Twist message to the topic /base_controller/command. You can read the odometry with the topic /pose, which is of type nav_msgs::Odometry.

If you need a Tutorial, this one will supply code for reading the position data, and this one will supply code for sending velocity commands.


According to the pastebin output, you checked out the package vanderbilt-ros-pkg... You need to check out vanderbilt-p2os. It also appears you are trying to build from your Downloads directory.

So, you need to make yourself a workstation. This should create a workstation and download the code.

mkdir -p ~/ros_ws/src
cd ~/ros_ws/src
catkin_init_workspace
cd ~/ros_ws/
catkin_make
source devel/setup.bash
echo "source ~/ros_ws/devel/setup.bash" >> ~/.bashrc
cd src && git clone https://github.com/allenh1/p2os.git
source ../devel/setup.bash
rosmake p2os

Ok. The package you mentioned is included within the PR2 packages. Easy fix, thankfully! I think this should do it:

sudo apt-get install ros-groovy-pr2-controllers

The error you got when you tried to run the above command is a dependency problem. Do as the terminal says. You probably have some broken packages on your system. As for trying the source, check to make sure you placed the source in the ~/ros_ws/src directory and built it there. If you failed to put it within your ROS environment, ROS cannot find it.

edit flag offensive delete link more

Comments

Thank you for your answer. We would love to you use your package, we tried to start it, but we don't know how it works together. Maybe you can give us a small explanation, how we could start it. we're new in ROS, so we still need help. :-)

roman27 gravatar image roman27  ( 2013-06-11 23:10:54 -0500 )edit

Please edit your question instead of posting new answers. I have done so for you.

allenh1 gravatar image allenh1  ( 2013-06-17 06:23:43 -0500 )edit

I will edit my answer on my own, but for now i willdeactivate the links ;) low karma. I've already tried that. Thank you for help.

roman27 gravatar image roman27  ( 2013-06-17 07:34:46 -0500 )edit

So thank you we finally repaired the decency. Also we could finally build the joystick driver and after that we build the p2os successfully. Now the Robot drives with some simple command line codes. Be aware of your next questions in a new thread ;) thanks.

roman27 gravatar image roman27  ( 2013-06-18 05:30:49 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-06-11 05:34:41 -0500

Seen: 668 times

Last updated: Jun 17 '13