Fedora 18 - ROS Fuerte installation problem [closed]

asked 2013-06-08 10:52:32 -0500

Peter Roos gravatar image

Hi,

I'm following the installation notes found on ros.org for Fedora - link

Last successful move:

rosinstall --catkin ~/ros-underlay http://ros.org/rosinstalls/fuerte-ros-full.rosinstall

Then the following:

cd ~/ros-underlay
mkdir build
cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/opt/ros/fuerte -DSETUPTOOLS_DEB_LAYOUT=OFFLS_DEB_LAYOUT=OFF

The last command fails, noting that:

-- Could NOT find Boost
CMake Error at rospack/CMakeLists.txt:31 (message):
Couldn't find Boost
-- Configuring incomplete, errors occurred!

I've checked the CMakeList.txt in rospack, at line 31:

find_package(Boost 1.40.0 COMPONENTS system filesystem program_options)
if(NOT Boost_FOUND)
  message(FATAL_ERROR "Couldn't find Boost")
endif()

I've noticed, that on my system - Fedora 18 x64 - the boost package is version 1.50.0. Replacing the numbers did not help. I've also tried to replace this code by a solution from stackoverflow:

FIND_PACKAGE(Boost)
IF (Boost_FOUND)
    INCLUDE_DIRECTORIES(${Boost_INCLUDE_DIR})
    ADD_DEFINITIONS( "-DHAS_BOOST" )
ENDIF()

None of these worked.

Btw, is a full ROS install from source on Fedora a feasible task?

I've used 12.04 only for ROS, but I like Fedora better. It would be nice to have ROS working on this system.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-05-29 13:01:08.056202