Ask Your Question
2

Fuerte Explore package in a real environment problem (again)

asked 2013-06-06 09:50:07 -0500

Zayin gravatar image

updated 2013-06-12 05:49:27 -0500

I created my own Explore package to be used in the real world. My package is basically identical to Explore_stage (http://www.ros.org/wiki/explore) with a few modifications to the XML, yaml and launch files, and altered to use gmapping as its map. Moreover, I have changed explore.cpp according to the 2 TODO comments. My modified package can be found here: https://github.com/LadyZayin/explore

Explore works well on Stage (I receive many warnings, but it works). In the real world, the robot stops moving after exploring for a small while; it wanders across half of the room for some time (ranging from 10 seconds to 5 minutes), then it stops. If I wait for several minutes, it sometimes restarts moving for a few seconds, then stops again. I receive many of the following warning in the terminal: [ WARN] [1370547349.514586524]: Entropy has not been updated. Loop closure opportunities may be ignored. I don't know if both problems are related.

Any ideas?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2013-06-11 03:23:04 -0500

jannik.laval gravatar image

Hi,

I am using your configuration to try to work with Turtlebot. On Groovy, when I did a "rostopic echo /move_base/status", I received a lot of message to say that the goal has been cancelled by a new one. So, I reduce the frequency for the planner, and the turtlebot works:

I hope it can help you.

edit flag offensive delete link more

Comments

I'm glad my package worked for you (and on Groovy on top of that)! I'm happy my work has shown to be useful after all the questions I've asked here lol. Anyway, I'll try your suggestion and post the outcome. Thanks! By the way, what is the frequency that worked for you?

Zayin gravatar image Zayin  ( 2013-06-11 04:45:13 -0500 )edit

I added this value: <param name="planner_frequency" value="0.08"/>, but it seems to depend on the size of the room. I don't understand why the algorithm don't use the move_base status feedback

jannik.laval gravatar image jannik.laval  ( 2013-06-11 05:14:33 -0500 )edit

Isn't that frequency too small? Did you mean 0.8? Or is it supposed to be very slow? It doesn't seem to help that much.

Also, in which file have you put your line? explore_slam.xml?

Zayin gravatar image Zayin  ( 2013-06-11 06:12:02 -0500 )edit

I forgot to mention something. Have you modified explore.cpp in the main Explore folder? I have followed the suggestions in both TODOs. Maybe that's causing issues. I will revert them back and see what happens.

Zayin gravatar image Zayin  ( 2013-06-11 06:53:00 -0500 )edit

It is not too small: the explore node use a simple goal server. It means that when it send a goal, it override the previous one. This is why the robot doesn't move: it always cancel the destination. I added the line in explore_slam.xml.

jannik.laval gravatar image jannik.laval  ( 2013-06-11 07:03:16 -0500 )edit

I found the parameter in the explore.cpp file. But I don't change the explore.cpp. What do you change in that file ?

jannik.laval gravatar image jannik.laval  ( 2013-06-11 07:05:30 -0500 )edit

In fact, to determine the frequency, just run this line "rostopic echo /move_base/status" and see if there is too much canceling goals

jannik.laval gravatar image jannik.laval  ( 2013-06-11 07:06:48 -0500 )edit

There are two comments in explore.cpp labelled as TODO. Unless the Groovy version is different? But I think they're the same, aren't they?

Zayin gravatar image Zayin  ( 2013-06-11 07:18:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-06-06 09:50:07 -0500

Seen: 607 times

Last updated: Jun 12 '13