Ask Your Question
0

ERROR WITH INSTALLING

asked 2013-05-26 09:27:12 -0500

eng.mostafa gravatar image

HI,I have this error while installing the ros mostafa@mostafa-HP:~$ sudo apt-get install ros-fuerte-desktop-full [sudo] password for mostafa: Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: ros-fuerte-desktop-full : Depends: ros-fuerte-slam-gmapping (= 1.2.7-s1367611780~oneiric) but it is not going to be installed Depends: ros-fuerte-simulator-gazebo (= 1.6.16-s1367578740~oneiric) but it is not going to be installed Depends: ros-fuerte-visualization (= 1.8.17-s1367597096~oneiric) but it is not going to be installed Depends: ros-fuerte-vision-opencv (= 1.8.8-s1367534634~oneiric) but it is not going to be installed Depends: ros-fuerte-perception-pcl (= 1.2.3-s1367551894~oneiric) but it is not going to be installed Depends: ros-fuerte-image-pipeline (= 1.8.5-s1367578071~oneiric) but it is not going to be installed Depends: ros-fuerte-image-transport-plugins (= 1.8.6-s1367550790~oneiric) but it is not going to be installed Depends: ros-fuerte-visualization-tutorials (= 0.6.3-s1367612594~oneiric) but it is not going to be installed Depends: ros-fuerte-laser-pipeline (= 1.4.5-s1367578924~oneiric) but it is not going to be installed Depends: ros-fuerte-navigation (= 1.8.3-s1367596830~oneiric) but it is not going to be installed E: Unable to correct problems, you have held broken packages.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-05-26 18:13:06 -0500

updated 2013-05-27 02:29:39 -0500

Be sure of setup your sources according to your distribution (See Installing guide for groovy in Ubuntu, Item 1.2). Or if you want to install fuerte, see this.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-26 09:27:12 -0500

Seen: 112 times

Last updated: May 27 '13