ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Problem with the Terminal (ROS_DISTRO)

asked 2013-05-12 15:43:31 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hello Everyone!!

I have a problem with my Terminal, when I open it get this error: ROS_DISTRO was set to 'fuerte' before. Please make sure that the environment does not mix paths from different distributions.

And when I have used: source /opt/ros/groovy/setup.bash

Best, Vincent

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-05-12 18:00:01 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

This warning just means that some of the ROS environment variables were already set when the /opt/ros/groovy/setup.bash file was executed. The most likely cause of this is an unintentional line in your ~/.bashrc file. If, for example, your .bashrc "sourced" the setup.bash for Fuerte before the one for Groovy, you would see this error. Note that the unintentional line could possibly be in other bash startup scripts (such as ~/.profile).

At any time, you can use env |grep ROS to see all of the ROS environment variables. If none of them are pointing to Fuerte stuff, you are probably fine. Although, you should probably figure out the source of this warning and remove it anyway. Note you can always use the unset command to remove any stray environment variables.

edit flag offensive delete link more


When I used: env |grep ROS







vncntmh gravatar image vncntmh  ( 2013-05-22 17:41:06 -0500 )edit

I have two ROS groovy and fuerte

vncntmh gravatar image vncntmh  ( 2013-05-22 17:42:04 -0500 )edit

Question Tools

1 follower


Asked: 2013-05-12 15:43:31 -0500

Seen: 15,253 times

Last updated: May 12 '13