Ask Your Question
1

howto install usb_cam on ROS Groovy

asked 2013-05-02 23:43:07 -0500

ZoltanS gravatar image

updated 2013-05-07 02:08:08 -0500

Hi!

I would like to install usb_cam from BOSCH on Groovy on Ubuntu 12.04 64 bit. I already managed it to install and make it work on a different laptop on Ubuntu 12.04 32 bit, but I can't remember the exact steps.

What I tried is: I created and setup a workspace in my home, I downloaded the source files and wanted to compile it. There were no errors during the compilation, but apparently no binaries were created, as it also said during compilation "ROS_NOBUILD in package ...".

Could please someone describe the process step by step?

Edit 1: In the meanwhile I installed almost all the ros packages, and then it worked. However I don't know which package(s) was/were missing for the compilation of the usb_cam.

Edit 2: A different approach, as proposed by @joq in his answer, is to install usb_cam from the ros-shadow-fixed repository. I managed to install it on my machine, however, strangely at first apt was looking for several 32 bit dependencies and denied to install, but a couple of minutes and several tries later it was installed. Before you ask, I did apt-get update after adding the repository. Now I just have to find out, how can I make a camera node and a launch file, but it is a different question.

Edit 3: the binary usb_cam_node file is missing from the installation.

Edit 4: with the newest ros-groovy-usb-cam v.0.1.2 driver (from the ros-shadow-fixed repository) it is working great.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2013-05-04 05:23:24 -0500

joq gravatar image

updated 2013-05-06 06:01:04 -0500

Why not just install the binaries?

sudo apt-get install ros-groovy-usb-cam

UPDATE: that package is not yet in the main repository, I found it in shadow-fixed. It should be released soon.

To get it right now, edit your /etc/apt/sources.list.d/ros-latest.list to ros-shadow-fixed, like this:

deb http://packages.ros.org/ros-shadow-fixed/ubuntu precise main

UPDATE2: as @ZoltanS discovered, that shadow-fixed package is not installing the usb_cam_node (or much of anything else). Apparently, it is being converted to catkin, but the conversion is not yet complete.

If you want to build from source, the Fuerte version (0.4.2) is still using rosbuild. Building that on Groovy with rosmake will probably work.

This driver is not yet released to Groovy, but I will notify the maintainer anyway, to make sure he knows about this problem.

edit flag offensive delete link more

Comments

In which repository is it? I can't find it on the net. There is a ros-fuerte-usb-cam package, but as the name says it is for fuerte and not for groovy. Did you found the package for groovy?

ZoltanS gravatar image ZoltanS  ( 2013-05-05 21:32:28 -0500 )edit

Thanks for the instructions. Unfortunately, it seems to only work for i386, it requires a lot of i386 dependency packages, which can not be installed on my 64bit machine.

ZoltanS gravatar image ZoltanS  ( 2013-05-06 03:04:55 -0500 )edit

It installs fine on my 64-bit Precise machine. Please edit your original question, adding what you did and what errors you saw.

joq gravatar image joq  ( 2013-05-06 03:19:35 -0500 )edit

Now it also installed it on my computer. I don't know what the problem was.

ZoltanS gravatar image ZoltanS  ( 2013-05-06 03:53:12 -0500 )edit

Good to hear. I recommend restoring your APT sources to the regular ROS repo now that the driver is installed.

joq gravatar image joq  ( 2013-05-06 04:13:42 -0500 )edit

thanks joq! I am missing the usb_cam_node which is normally in the bin library if usb_cam is compiled from the source. I am afraid I don't know how to use the package without the usb_cam_node. Do you have this file in your package?

ZoltanS gravatar image ZoltanS  ( 2013-05-06 05:02:34 -0500 )edit

The missing install files have been fixed in usb_cam 0.1.2 which was just pushed. It should be making its way through the build farm shortly which should fix the debian package installation.

rtoris288 gravatar image rtoris288  ( 2013-05-06 06:36:15 -0500 )edit

Many thanks @joq and @rtoris288, it is working now with the newest 0.1.2 driver.

ZoltanS gravatar image ZoltanS  ( 2013-05-07 02:05:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-02 23:43:07 -0500

Seen: 2,914 times

Last updated: May 07 '13