Ask Your Question
1

Problem with rgbdslam and QVGA resolution

asked 2013-04-28 01:01:49 -0600

Alex2309 gravatar image

updated 2014-01-28 17:16:22 -0600

ngrennan gravatar image

Hi, I'm trying to run rgbdslam with the openni_launch packet setted to qvga via dynamic reconfigure, but when I try I get the following error:

[ERROR] [1367146343.993708402]: PointCloud, depth and visual image differ in size! Ignoring Data

If I try to visualize the rgbdcloud from the openni driver in rviz instead I get this error message:

Error updating depth cloud: Depth image size and camera info don't match: 320 x 240 vs 640 x 480(binning: 1 x 1, ROI size: 640 x 480)

So the problems seems to be the published camera info. In fact, it works just fine with vga 30hz or 25hz modality. What I have done is only setting the image_mode and depth_mode parameter to QVGA(30hz) via dynamic reconfigure, am i supposed to do something else?

I'm currently using an asus xtion pro live with rosgroovy on ubuntu 12.10.

Any advice is welcome! Thank you in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-04-28 22:12:54 -0600

updated 2013-04-30 04:04:19 -0600

Hi Alex, I've played around with QVGA and also had the problem with the wrong camera info. I think I included some hack to workaround this, but the support for qvga resolution in rgbdslam may be a bit brittle and require fiddling with the settings as I didn't test it much. I am interested in the related bug reports though.

Anyway, the first error you get is because you do not change both images (rgb+depth) to qvga, but just one of them.

Edit:

I checked and I don't get that error. However, I do have problems changing to qvga while everything runs, so I start roslaunch openni_launch openni.launch, then use dynamic reconfigure to switch rgb and depth to QVGA. Then I start rgbdslam (without openni).

Edit2: I've checked in a workaround for the camera_info problem. Have a look at the new launchfile "qvga-kinect+rgbdslam.launch", it should work "out of the box".

edit flag offensive delete link more

Comments

Hi, thank you for the reply. So right now there's no way to use lower resolution for the slam process?

For the first error i setted both image_mode and depth_mode to the same resolution, but i get the same error anyway

Edit: thank you with the new lauchfile works just fine!!

Alex2309 gravatar imageAlex2309 ( 2013-04-28 23:05:33 -0600 )edit

You're welcome. Interestingly I noticed that for qvga surf is faster than siftgpu. Might depend on the graphics card and driver though.

Felix Endres gravatar imageFelix Endres ( 2013-05-01 02:08:43 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-28 01:01:49 -0600

Seen: 365 times

Last updated: Apr 30 '13