Ask Your Question
0

rosmake sbpl_interface - problem with missing dependency

asked 2013-04-26 04:00:04 -0500

rosrookie gravatar image

updated 2013-05-02 13:07:11 -0500

Hello,

I would be happy for any commentary or answer. If I expressed myself unclear, please tell me.

Background: the package sbpl_interface requires the collision_distance_field-package as a dependency.

Approach: The package collision_distance_fieldis located inside of the moveit_core package. Due there is a package.xml file in it I put the whole MoveIt!_source-folder in my catkin_worspace under /src. After catkin_make was successful, the package collision_distance_field is still missing:

faps@faps-Aspire-5740D:~/catkin_ws/src$ rosmake sbpl_interface
  .................
  [rosbuild] Building package sbpl_interface
  Failed to invoke /opt/ros/groovy/bin/rospack deps-manifests sbpl_interface
  [rospack] Error: package/stack 'sbpl_interface' depends on non-existent package 'collision_distance_field' and rosdep claims that it is not a system dependency. Check the ROS_PACKAGE_PATH or try calling 'rosdep update'


  CMake Error at /opt/ros/groovy/share/ros/core/rosbuild/public.cmake:129 (message):


    Failed to invoke rospack to get compile flags for package 'sbpl_interface'.
    Look above for errors from rospack itself.  Aborting.  Please fix the
    broken dependency!

  Call Stack (most recent call first):
    /opt/ros/groovy/share/ros/core/rosbuild/public.cmake:203 (rosbuild_invoke_rospack)
    CMakeLists.txt:12 (rosbuild_init)


  -- Configuring incomplete, errors occurred!
-------------------------------------------------------------------------------}
[ rosmake ] Output from build of package sbpl_interface written to:
[ rosmake ]    /home/faps/.ros/rosmake/rosmake_output-20130430-014403/sbpl_interface/build_output.log
[rosmake-2] Finished <<< sbpl_interface [FAIL] [ 0.88 seconds ]                 
[ rosmake ] Halting due to failure in package sbpl_interface. 
[ rosmake ] Waiting for other threads to complete.
[ rosmake ] Results:                                                            
[ rosmake ] Built 39 packages with 1 failures.                                  
[ rosmake ] Summary output to directory                                         
[ rosmake ] /home/faps/.ros/rosmake/rosmake_output-20130430-014403

Info: rosdep update also fails.

Questions:

  1. How can I fix the missing dependency?

  2. I've allready installed MoveIt!-Full via sudo apt-get install ros-groovy-moveit-full, shouldn't moveit_core with all contained packages already be installed?

Many Thanks in advance rosrookie

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-05-15 11:18:04 -0500

Sachin Chitta gravatar image

Hi rosrookie,

Thanks for giving MoveIt! a try. Unfortunately, sbpl_interface has not been fully ported to the latest version of MoveIt! yet which is why its not working. The authors are working on updating it right now and we'll let you know as soon as its fully up and running.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-26 04:00:04 -0500

Seen: 189 times

Last updated: May 15 '13