Rviz fails to start [closed]

asked 2013-04-21 07:46:26 -0600

amine23 gravatar image

updated 2013-04-24 06:01:22 -0600

Hi,

I am not able to get Rviz to run

When I type in terminal:

rosrun rviz rviz

I get :

(rviz:9663): Gtk-CRITICAL **: IA__gtk_settings_set_long_property: assertion `GTK_SETTINGS (settings)' failed

(rviz:9663): Gtk-CRITICAL **: IA__gtk_settings_set_long_property: assertion `GTK_SETTINGS (settings)' failed

and nothing happen.

Any clues ??

EDIT:

@dgossow I think Gazebo is gtk based. I get the same gtk-critical stuff but it works fine.

I typed the command you wrotte, and it does not even want to halt when I press ctrl-c :

Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /opt/ros/groovy/lib/rviz/rviz...(no debugging symbols found)...done.
(gdb) ^CQuit
(gdb) ^CQuit
(gdb) ^CQuit

EDIT2:

Here is the backtrance :

#0  0xb7fdd424 in __kernel_vsyscall ()
#1  0xb6fc65f0 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb576674b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb5757d00 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb5757e61 in g_main_context_iteration ()
   from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb5fb39a1 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#6  0xb73899aa in ?? () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#7  0xb5f8028c in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#8  0xb5f80581 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib/i386-linux-gnu/libQtCore.so.4
#9  0xb5f85cda in QCoreApplication::exec() ()
   from /usr/lib/i386-linux-gnu/libQtCore.so.4
#10 0xb72d0fc4 in QApplication::exec() ()
   from /usr/lib/i386-linux-gnu/libQtGui.so.4
#11 0x08048da7 in main ()
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-12-12 01:24:14.421250

Comments

does your computer have nvidia graphics card ?

prasanna.kumar gravatar imageprasanna.kumar ( 2013-04-21 07:53:17 -0600 )edit

@prasanna.kumar no but ati and using proprietary driver

amine23 gravatar imageamine23 ( 2013-04-21 20:38:00 -0600 )edit

Please run rviz in gdb (gdb /opt/ros/groovy/lib/rviz/rviz, on the gdb shell enter run), then ctrl-c it and provide a backtrace of where it is stuck (bt).

dgossow gravatar imagedgossow ( 2013-04-22 05:36:13 -0600 )edit

What versions of ROS and Ubuntu are you using?

Eric Perko gravatar imageEric Perko ( 2013-04-22 06:20:39 -0600 )edit

@EricPerko groovy on quantal. everything is up to date.

amine23 gravatar imageamine23 ( 2013-04-22 07:25:38 -0600 )edit

@dgossow when I run it from gdb without roscore it starts and tell me waiting for master. If I run roscore : sometimes it doesn't start, it give the same gtk-critical msgs and when I ctrl-c it I get : Program received signal SIGINT, Interrupt. 0xb4de777f in ?? () from /lib/i386-linux-gnu/libpcre.so.

amine23 gravatar imageamine23 ( 2013-04-22 21:24:10 -0600 )edit
amine23 gravatar imageamine23 ( 2013-04-22 21:35:19 -0600 )edit

Disable desktop effects before running RViz. Also, you need to type run in gdb to actually start RViz.

dgossow gravatar imagedgossow ( 2013-04-23 08:15:09 -0600 )edit