Ask Your Question
1

RQT_GUI fails after upgrade

asked 2013-04-02 22:14:56 -0500

Gav gravatar image

After upgrading RQT_GUI now fails when run:

turtlebot@turtleVM:~$ rosrun rqt_gui rqt_gui 
WARNING: Package name "swig-wx" does not follow the naming conventions. It should start with a lower case letter and only contain lower case letters, digits and underscores.
WARNING: Package name "swig-wx" does not follow the naming conventions. It should start with a lower case letter and only contain lower case letters, digits and underscores.
Traceback (most recent call last):
  File "/opt/ros/groovy/lib/rqt_gui/rqt_gui", line 16, in <module>
    sys.exit(main.main())
  File "/opt/ros/groovy/lib/python2.7/dist-packages/rqt_gui/main.py", line 57, in main
    return super(Main, self).main(argv, standalone=standalone, plugin_argument_provider=plugin_argument_provider)
  File "/opt/ros/groovy/lib/python2.7/dist-packages/qt_gui/main.py", line 479, in main
    plugin_manager.discover()
  File "/opt/ros/groovy/lib/python2.7/dist-packages/qt_gui/plugin_manager.py", line 108, in discover
    self._plugin_menu.add_plugin(plugin_descriptor)
  File "/opt/ros/groovy/lib/python2.7/dist-packages/qt_gui/plugin_menu.py", line 79, in add_plugin
    self._enrich_action(action, action_attributes, base_path)
  File "/opt/ros/groovy/lib/python2.7/dist-packages/qt_gui/plugin_menu.py", line 130, in _enrich_action
    raise UserWarning('icon "%s" not found' % str(path))
UserWarning: icon "../src/kobuki_qtestsuite/resources/images/kobuki_icon.png" not found

Had this happen on a couple of machines, so quite sure it's not my setup. All packages are now upgraded and nothing is held back.

Seems like the recent upgrades broke a lot of things. Is this a weird situation due to ROS changing hands, or is it unrelated to that?

I've spent a day of leave just trying to get stuff working again, and looks like I won't have my turtlebot running for MakerFaire Adelaide.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-04-03 07:39:40 -0500

130s gravatar image

It's because the recent faulty release. We're working on it, and looks like the fix is ready to be released into public (although it might take several days. I'm not sure when is the next release date).

Quick workaround if you don't use rqt with kobuki, uninstall kobuki pkgs should work (so far I've only seen this issue to happen when kobukis are installed). But just to be clear, the root cause is in qt_gui_core metapackage and kobuki is not doing any harm.

Sorry for any inconvenience.

edit flag offensive delete link more

Comments

Thanks, Issac. I'll keep my eyes out for the new release.

Gav gravatar image Gav  ( 2013-04-03 10:06:41 -0500 )edit

Now the fixed version (qt_gui_core 0.2.15-1) is available publicly.

130s gravatar image 130s  ( 2013-04-04 08:09:37 -0500 )edit
1

answered 2013-04-03 00:43:59 -0500

creation gravatar image

Hello there!

Try to edit source in the end of ~/.bashrc file. I've erase repetitive lines for sources and it worked for me.

GL!

edit flag offensive delete link more

Comments

Thanks Creation, I had a check and there was a repeated setup.bash in there, but after removing it and opening a new terminal the problem is still there.

Gav gravatar image Gav  ( 2013-04-03 01:03:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-04-02 22:14:56 -0500

Seen: 412 times

Last updated: Apr 03 '13