Ask Your Question
0

liblapack3gf imoprt error with py when running arbotix example from ROSByExample

asked 2013-03-27 19:11:22 -0500

Juan gravatar image

updated 2014-01-28 17:15:56 -0500

ngrennan gravatar image

Ubuntu 1210

Groovy

When I run the very first example in ROSByExample (Fuerte) in Section 6.2 Testing the simulator, we call:

I get an error that seems to indicate that states "Import Error: liblapack.so.3gf: cannot open shared object file: No such file or directory". But I am sure I have this lib in my computer. The complete console output is:


started roslaunch server http://vmrg-xps-15:42951/

SUMMARY
========

PARAMETERS
 * /arbotix/baud
 * /arbotix/controllers/base_controller/Kd
 * /arbotix/controllers/base_controller/Ki
 * /arbotix/controllers/base_controller/Ko
 * /arbotix/controllers/base_controller/Kp
 * /arbotix/controllers/base_controller/accel_limit
 * /arbotix/controllers/base_controller/base_frame_id
 * /arbotix/controllers/base_controller/base_width
 * /arbotix/controllers/base_controller/ticks_meter
 * /arbotix/controllers/base_controller/type
 * /arbotix/port
 * /arbotix/rate
 * /arbotix/read_rate
 * /arbotix/sim
 * /arbotix/sync_read
 * /arbotix/sync_write
 * /arbotix/write_rate
 * /robot_description
 * /robot_state_publisher/publish_frequency
 * /rosdistro
 * /rosversion
 * /use_sim_time

NODES
  /
    arbotix (arbotix_python/driver.py)
    odom_left_wheel_broadcaster (tf/static_transform_publisher)
    odom_right_wheel_broadcaster (tf/static_transform_publisher)
    robot_state_publisher (robot_state_publisher/robot_state_publisher)

ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found
process[arbotix-1]: started with pid [16038]
process[robot_state_publisher-2]: started with pid [16039]
[ERROR] [1364446895.621811044]: No name given for the robot.
[ERROR] [1364446895.622006176]: Could not generate robot model
[ERROR] [1364446895.622057192]: Failed to extract kdl tree from xml robot description
process[odom_left_wheel_broadcaster-3]: started with pid [16055]
process[odom_right_wheel_broadcaster-4]: started with pid [16074]
[robot_state_publisher-2] process has died [pid 16039, exit code 255, cmd /opt/ros/groovy/lib/robot_state_publisher/robot_state_publisher __name:=robot_state_publisher __log:=/home/vmrguser/.ros/log/062413d2-975b-11e2-b17e-c48508b13bfe/robot_state_publisher-2.log].
log file: /home/vmrguser/.ros/log/062413d2-975b-11e2-b17e-c48508b13bfe/robot_state_publisher-2*.log
Traceback (most recent call last):
  File "/home/vmrguser/rosGWS/sandbox/ROSByExample/arbotix/arbotix_python/nodes/driver.py", line 38, in <module>
    from arbotix_python.diff_controller import DiffController
  File "/home/vmrguser/rosGWS/sandbox/ROSByExample/arbotix/arbotix_python/src/arbotix_python/diff_controller.py", line 38, in <module>
    from tf.broadcaster import TransformBroadcaster
  File "/opt/ros/groovy/lib/python2.7/dist-packages/tf/__init__.py", line 29, in <module>
    from listener import TransformListener, TransformerROS
  File "/opt/ros/groovy/lib/python2.7/dist-packages/tf/listener.py", line 34, in <module>
    from tf import transformations
  File "/opt/ros/groovy/lib/python2.7/dist-packages/tf/transformations.py", line 174, in <module>
    import numpy
  File "/usr/lib/python2.7/dist-packages/numpy/__init__.py", line 137, in <module>
    import add_newdocs
  File "/usr/lib/python2.7/dist-packages/numpy/add_newdocs.py", line 9, in <module>
    from numpy.lib import add_newdoc
  File "/usr/lib/python2.7/dist-packages/numpy/lib/__init__.py", line 13, in <module>
    from polynomial import *
  File "/usr/lib/python2.7/dist-packages/numpy/lib/polynomial.py", line 17, in <module>
    from numpy.linalg import eigvals, lstsq
  File "/usr/lib/python2.7/dist-packages/numpy/linalg/__init__.py", line 48, in <module>
    from linalg import *
  File "/usr/lib/python2.7/dist-packages/numpy/linalg/linalg.py", line 23, in <module>
    from numpy.linalg import lapack_lite
ImportError: liblapack.so.3gf: cannot open shared object file: No such file or directory
[arbotix-1] process has died [pid 16038, exit code 1, cmd /home/vmrguser/rosGWS/sandbox/ROSByExample/arbotix/arbotix_python/nodes/driver.py __name:=arbotix __log:=/home/vmrguser/.ros/log/062413d2-975b-11e2-b17e-c48508b13bfe/arbotix-1.log].
log file: /home/vmrguser/.ros/log/062413d2-975b-11e2-b17e-c48508b13bfe/arbotix-1*.log ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2013-03-27 19:23:10 -0500

Juan gravatar image

updated 2013-03-27 22:29:15 -0500

The problem appears in the numpy/linalg/linalg.py module.

When I list the package using dpkg this is what i get:


 dpkg -l liblapack3gf 
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  liblapack3gf   3.4.1-6      all          Transitional package for liblapac

I tried to reinstall the lib using sudo aptitude reinstall liblapack3gf but it did not work. I tried to do it for libblas3gf but also no effect.

I uninstalled libblas* and liblapack* and then reinstalled and that seemed to have helped. But the simulator in rviz still does not show properly...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-27 19:11:22 -0500

Seen: 409 times

Last updated: Mar 27 '13