Ask Your Question
1

Issue building tf2_ros on OSX

asked 2013-03-26 01:56:02 -0600

updated 2013-03-26 01:56:44 -0600

I'm running into this problem while trying to build tf2_ros on OSX:

==> make -j4 -l4 in '/Users/Yeison/ros_catkin_ws/build_isolated/tf2_ros'
Linking CXX shared library /Users/Yeison/ros_catkin_ws/devel_isolated/tf2_ros/lib/libtf2_ros.dylib
Undefined symbols for architecture x86_64:

Full output: https://gist.github.com/yeison/5244835

I think the following patch is meant to address the issue:
https://github.com/ros/geometry-experimental/pull/6

I'll have to try and pull those changes in locally to test.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-03-26 02:18:25 -0600

updated 2013-03-26 02:23:19 -0600

I'll have to try and pull those changes in locally to test.

That seems to have worked!

https://github.com/ros/geometry-experimental/pull/6

edit flag offensive delete link more

Comments

1

I just ran into this as well and the fix worked fine! Thx a lot!

Markus Achtelik gravatar imageMarkus Achtelik ( 2013-03-26 05:56:38 -0600 )edit

I'm glad that helped. Thanks to @WilliamWoodall for that patch.

Yeison Rodriguez gravatar imageYeison Rodriguez ( 2013-03-29 14:25:18 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-26 01:56:02 -0600

Seen: 543 times

Last updated: Mar 26 '13