Ask Your Question
3

errors installing groovy on mac osx homebrew (pydot)

asked 2013-03-20 18:45:10 -0500

Mike Bosse gravatar image

I am getting the following error while trying to do a fresh install of groovy on my mac (10.7.5) with homebrew:

Any suggestions?

$ rosdep install --from-paths src --ignore-src --rosdistro groovy -y
executing command [sudo pip install -U pydot]
Password:
Downloading/unpacking pydot
  Running setup.py egg_info for package pydot
    Couldn't import dot_parser, loading of dot files will not be possible.

Downloading/unpacking pyparsing (from pydot)
  Running setup.py egg_info for package pyparsing
    Traceback (most recent call last):
      File "<string>", line 14, in <module>
      File "/Users/mike/ros_catkin_ws/build/pyparsing/setup.py", line 9, in <module>
        from pyparsing import __version__ as pyparsing_version
      File "pyparsing.py", line 629
        nonlocal limit,foundArity
                     ^
    SyntaxError: invalid syntax
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):

  File "<string>", line 14, in <module>

  File "/Users/mike/ros_catkin_ws/build/pyparsing/setup.py", line 9, in <module>

    from pyparsing import __version__ as pyparsing_version

  File "pyparsing.py", line 629

    nonlocal limit,foundArity

                 ^

SyntaxError: invalid syntax

----------------------------------------
Command python setup.py egg_info failed with error code 1
Storing complete log in /Users/mike/.pip/pip.log
ERROR: the following rosdeps failed to install
  pip: command [sudo pip install -U pydot] failed
edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
3

answered 2013-03-21 08:05:26 -0500

William gravatar image

Looks like pyparsing switched its default version to py3k only:

http://pyparsing.wikispaces.com/News

I guess you will have to install version 1.5.7 explicitly:

$ sudo pip install pyparsing==1.5.7

I haven't run into this, but I assume that's because I already have pyparsing installed from before this change.

edit flag offensive delete link more
1

answered 2013-03-24 20:49:23 -0500

130s gravatar image

To kind of sort out what @William and @Mike Bosse posted, I had to run:

$ sudo easy_install pyparsing==1.5.7
$ sudo easy_install pydot
$ sudo pip install pyparsing==1.5.7
edit flag offensive delete link more
1

answered 2013-03-21 13:12:32 -0500

Mike Bosse gravatar image

Yes pyparsing needs to be version 1.5.7, but I needed to run the following commands to get it to work:

easy_install pyparsing==1.5.7
easy_install pydot

since the rosdep install for pydot would get its own (incorrect) version of pyparsing.

Thanks!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-03-20 18:45:10 -0500

Seen: 1,290 times

Last updated: Mar 24 '13