ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

rosserial error on Raspbian

asked 2013-03-13 16:37:33 -0500

updated 2014-01-28 17:15:40 -0500

ngrennan gravatar image

I am trying to use rosserial on Raspbian using ROS Groovy. I am trying to run rosrun rosserial_python /dev/ttyACM0 but I get this error [ERROR] [WallTime: 1363226987.379253] Tried to publish before configured, topic id 125. I compile the code on an Ubuntu 12.04 laptop and can get it to run on the Ubuntu machine but as soon as I plug it into the Raspberry Pi, I get that error. Any ideas?

Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-03-19 10:06:52 -0500

I upgrade the rosserial on the Raspi to the latest one and it worked locally on the Raspi but the Master could not echo the topic. Will the sudo apt-get ros-groovy-rosserial be updated to the latest version?

edit flag offensive delete link more



Debians only sync to public every so often. The updated rosserial is currently in shadow-fixed, so it will be in the next public sync, but I don't know when that will occur.

fergs gravatar image fergs  ( 2013-03-19 10:25:48 -0500 )edit

Is there a major difference between the current stable source version and one available from public sync?

tonybaltovski gravatar image tonybaltovski  ( 2013-03-19 17:13:18 -0500 )edit

Quite a bit. Originally, 0.2.0 got released by the groovy migration team as 0.3.0 wouldn't build. Recently we've released 0.4.x (currently 0.4.4 I believe). The 0.4.0 series has a number of fixes and improvements. It should be in public debians as of this last sync.

fergs gravatar image fergs  ( 2013-03-26 11:16:44 -0500 )edit

I installed the latest from source and it works fine. Thanks. The one from the public debians gave me problems. Any updates on rosserial_xbee?

tonybaltovski gravatar image tonybaltovski  ( 2013-03-26 11:46:45 -0500 )edit

rosserial_xbee has not been maintained for quite some time, as such it has been moved into the rosserial_experimental stack.

fergs gravatar image fergs  ( 2013-03-26 12:03:38 -0500 )edit

Is there a reason why it is not maintained? Will the kforge version work on groovy using rosmake?

tonybaltovski gravatar image tonybaltovski  ( 2013-03-26 12:17:10 -0500 )edit

Nobody has stepped forward to maintain it. It may work via rosmake, not entirely sure. We did move it to so that it would not be lost if Kforge eventually dies.

fergs gravatar image fergs  ( 2013-03-26 12:25:13 -0500 )edit

Is the package just lacking catkinization? Can you recommend a solution for wireless communicating to an Arduino?

tonybaltovski gravatar image tonybaltovski  ( 2013-03-26 12:31:16 -0500 )edit

Question Tools


Asked: 2013-03-13 16:37:33 -0500

Seen: 551 times

Last updated: Mar 19 '13