Ask Your Question
0

Dependecies problem (PCL / ros-fuerte-turtlebot) [closed]

asked 2013-03-12 14:11:01 -0500

Juan Manuel gravatar image

Hello guys,

I am having some problem to use my laptop as workstation for ROS. The problem is that I am actively using PCL and QT4 for some projects, and I have those packages installed. I also installed ROS-Fuerte to use as workstation for a turtlebot that I have. However, when I try to install the package ros-fuerte-turtlebot I get more than 1000 dependencies problems. aptitude recommends me to remove a lot of packages including

129 libpcl-1.6-all
130 libpcl-1.6-all-dev
131 libpcl-1.6-bin
132 libpcl-all

and

150 libqt4-dbus:i386
151 libqt4-declarative:i386
152 libqt4-designer:i386
153 libqt4-network:i386
154 libqt4-opengl:i386

Obviously I dont want to remove these packages, so my question is, how should I install the turtlebot packages for fuerte, without having to remove the other packages?

NOTE: Im using Ubuntu 12.04 AMD64. I am using Ros Fuerte in both my laptop and the turtlebot netbook.

Thanks in advance

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-11-16 01:41:31.507318

Comments

Did it ask to delete anything when you tried to install ros-fuerte-perception-pcl?

joq gravatar image joq  ( 2013-03-12 15:05:58 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-03-15 02:36:53 -0500

Juan Manuel gravatar image

Hello joq!

It didnt let me comment the question, but it didnt ask me to delete anything when I tried to install ros-fuerte-perception-pcl

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-03-12 14:11:01 -0500

Seen: 51 times

Last updated: Mar 15 '13