Ask Your Question
2

Anybody else seeing with rqt + rviz: adding camera and it crashes with segfault? [closed]

asked 2013-02-21 03:47:08 -0600

TommyP gravatar image

updated 2013-02-22 04:32:24 -0600

130s gravatar image

rqt and the adding rviz and then adding a camera and it crashes with segfault for me. Anybody else seeing that? I am using groovy and latest debs on Uuntu 12.04.

Running with gdb python and "run /opt/ros/groovy/bin/rqt":

[New Thread 0xa2478b40 (LWP 4596)]
[New Thread 0xa1c77b40 (LWP 4597)]
[New Thread 0xa1420b40 (LWP 4606)]
[Thread 0xac8ffb40 (LWP 4526) exited]

Program received signal SIGSEGV, Segmentation fault.
0xb6de98a8 in vtable for __cxxabiv1::__si_class_type_info ()
   from /usr/lib/i386-linux-gnu/libstdc++.so.6
(gdb) bt
#0  0xb6de98a8 in vtable for __cxxabiv1::__si_class_type_info ()
   from /usr/lib/i386-linux-gnu/libstdc++.so.6
(gdb) up
Initial frame selected; you cannot go up.
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by 130s
close date 2013-03-25 12:25:04

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-02-21 04:13:58 -0600

130s gravatar image

updated 2013-02-21 09:39:04 -0600

@TommyP can you run rqt_rviz in a debugger (see here for gdb for example) and send us the output when crashed again?

Also, what versions are you using? For example, what do these commands return?

dpkg -p ros-groovy-rqt
dpkg -p ros-groovy-rqt-rviz 
dpkg -p ros-groovy-qt-gui-core
dpkg -p ros-groovy-rviz

Without seeing these outputs I can't tell if it's the same but a ticket was opened and already closed a month ago, which should be already included in the latest debian pkg (eg. my ros-groovy-rqt-rviz is 0.2.8-0quantal-20130216-1454-+0000. Precise version shouldn't be that different). If yours is old, run these commands.

edit flag offensive delete link more

Comments

I cannot reproduce the error at home. Will check more at my work computer tomorrow. The version of for example ros-groovy-rqt-rviz at my work computer is 0.2.8-0precise-20130205-1933-+0000 which seems to be the latest version available for precise (had the same version on a computer i updated now),

TommyP gravatar imageTommyP ( 2013-02-21 07:08:37 -0600 )edit
1

I added what gdb says but it was not so informative.

TommyP gravatar imageTommyP ( 2013-02-22 03:50:48 -0600 )edit

Hm, I'm not sure either...it would be ideal to figure out the difference b/w your 2 machines where only 1 causes the issue, before opening a ticket here https://github.com/ros-visualization/rqt_robot_plugins/issues (I think rqt_rviz instead of rviz is the starting point for this ticket).

130s gravatar image130s ( 2013-02-22 03:57:09 -0600 )edit

One difference is that the one with the problem is 32-bits and the one without problem 64-bits. But you are right it might be something strange with my machine if nobody else see the problem. I will try to look into it more deeply after the weekend.

TommyP gravatar imageTommyP ( 2013-02-22 04:08:55 -0600 )edit

Clearing ROS_PACKAGE_PACK and sourcing /opt/ros/groovy/setup.bash solved the problem. Doing source devel/setup.bash in my catkin workspace and the problem appeared again. I cannot see anything obvious that can cause the seg fault. Any ideas about what to look for?

TommyP gravatar imageTommyP ( 2013-02-22 04:19:46 -0600 )edit

Yay you made it! However I'm still not sure..If you can reproduce it by manipulating ROS_PACKAGE_PATH and you're sure nothing is wrong in the setting that yields the problem, I think it's worth ticket.

130s gravatar image130s ( 2013-02-22 04:31:47 -0600 )edit

Question Tools

Stats

Asked: 2013-02-21 03:47:08 -0600

Seen: 622 times

Last updated: Feb 22 '13