Ask Your Question
0

chipkit max32 Lost sync with device, restarting...

asked 2013-02-18 08:17:10 -0500

packrat gravatar image

I am trying to run the rosserial tutorial "hello world" on a chipkit max 32. I can compile and upload to program to the max32. when I run "rosrun rosserial_python serial_node.py /dev/ttyUSB1", it returns ROS Serial Python Node Connected on /dev/ttyUSB1 at 57600 baud then after several seconds it returns [ERROR] Lost sync with device, restarting.... when I first start the python node the tx light blinks and every time the node tries to connect. I have read other posts, but non of them seem to answer or fix the issue. The max 32 is almost identical to the arduino due but it runs on a pic controller. I am using the latest mpide 23. I am not sure how to get it to connect and work.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-02-18 22:00:54 -0500

fergs gravatar image

Groovy or Fuerte? The release into Groovy is currently broken (but will hopefully be fixed very soon, there is quite a bit of activity on github.com/ros-drivers/rosserial.

edit flag offensive delete link more

Comments

Yes I am using groovy.

packrat gravatar image packrat  ( 2013-02-19 10:26:29 -0500 )edit

has rosserial been fixed yet? I tried installing it from source but not luck, it still says [ERROR] Lost sync with device, restarting....

packrat gravatar image packrat  ( 2013-03-11 11:26:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-18 08:17:10 -0500

Seen: 185 times

Last updated: Feb 18 '13