Ask Your Question
0

Turtlebot networking setup error

asked 2013-02-13 12:04:44 -0500

TheSkyfall gravatar image

Hello, I have a problem with networking setup. I followed this tut.

http://www.ros.org/wiki/Robots/TurtleBot/Network%20Setup

at the last step, on my workstation, I ran

rostopic pub -r10 /hello std_msgs/String "hello"

and when I ran

rostopic echo /hello

on my turtlebot laptop I got this:

WARNING: topic [/hello] does not appear to be published yet

according to the tut.

The message "hello" begin printed about 10 times a second.

but that is not happening.

Any suggestions will be appreciated.

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-03-05 21:02:28 -0500

Chik gravatar image

The standard way is to reboot both the workstation and the laptop, and then check:

echo $ROS_MASTER_URI

echo $ROS_HOSTNAME

In your workstation, the Master-URI should show the IP address of the TurtleBot laptop, but the hostname is the IP address (without http://) of the workstation.

Hope it helps.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-13 12:04:44 -0500

Seen: 62 times

Last updated: Mar 05 '13