Ask Your Question
1

Install on OSX fails with missing libboost_signals-mt.dylib

asked 2013-02-06 10:15:05 -0500

madmax gravatar image

updated 2013-02-08 07:21:36 -0500

Hi,

have a problem with OSX and groovy installation. Did anyone have to cope with this error? Should be installed...

-- Build files have been written to: /Users/max/ros_ws/geometry_experimental/tf2/build
cd build && make -j -l2
[  0%] Built target rospack_genmsg_libexe
[  0%] Built target rosbuild_precompile
Linking CXX shared library ../lib/libtf2.dylib
clang: warning: argument unused during compilation: '-pthread'
ld: library not found for -l:/usr/local/lib/libboost_signals-mt.dylib
clang: error: linker command failed with exit code 1 (use -v to see invocation)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2013-02-06 20:19:55 -0500

Hansg91 gravatar image

I had the same problem, it appears some pkg-config files are incorrect in ROS. Check my previous question for the solution:

http://answers.ros.org/question/54437/boost-signals-library-not-found/

edit flag offensive delete link more

Comments

Can't find a file with : in it.

madmax gravatar image madmax  ( 2013-02-08 07:20:38 -0500 )edit
1

Do you get anything if you execute : cd ~/ros_catkin_ws/install_isolated/lib/pkgconfig && grep -r 'l:/usr' *

Hansg91 gravatar image Hansg91  ( 2013-02-08 08:56:04 -0500 )edit

I found some libs and I can compile more packages. But I get the same error again with rospack_genmsg_libexe ... Edit: Works now, have to delete CMakeCache files ...

madmax gravatar image madmax  ( 2013-02-08 20:29:27 -0500 )edit
1

answered 2013-02-06 10:43:57 -0500

WilliamWoodall gravatar image

Does the file /usr/local/lib/libboost_signals-mt.dylib exist on your system? If not you may need to ensure boost is installed correctly on your system.

If you have recently reinstalled or updated boost then you might have stale build state, so you can try cleaning your CMake cache and rebuilding your packages to ensure they have up-to-date information.

edit flag offensive delete link more

Comments

Yes, boost is installed.

madmax gravatar image madmax  ( 2013-02-08 07:09:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-02-06 10:15:05 -0500

Seen: 367 times

Last updated: Feb 08 '13