Ask Your Question
0

RosJava and Eclipse

asked 2013-01-21 20:00:58 -0500

biyonder gravatar image

Hello guys!

I'm trying to run a java example interacting with ROS and from Eclipse. I followed this steps (http://www.ros.org/wiki/rosjava/TutorialsRun%20a%20ROS%20Android%20example%20project), and particularly when I type 'rosmake android_tutorial_camera' the output worked, but no .project and .classpath file is created, and hence I can not import the android_tutorial_camera project into Eclipse. Has somebody any idea of this?

Thanks in advance!

edit retag flag offensive close merge delete

Comments

rosjava does not support rosmake. The tutorial you're referencing is horribly out of date and I've deleted it. See http://ros.org/wiki/android_core

damonkohler gravatar image damonkohler  ( 2013-02-19 10:47:10 -0500 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2013-02-13 14:20:10 -0500

KazutoMurase gravatar image

But still can't put into operation for higher version android 'android_honeycomd_mr2' ...

Really? Now I can use both 'android_gingerbread_mr1' and 'android_honeycomb_mr2' libraries on eclipse.

edit flag offensive delete link more

Comments

1

Sry , now is working because both use same jar files , so when I choose only one as library and masterchooser.jar add to build path every think is now okey ;-)

LeopoldPodmolík gravatar image LeopoldPodmolík  ( 2013-02-13 22:34:35 -0500 )edit
0

answered 2013-02-01 00:52:46 -0500

LeopoldPodmolík gravatar image

Hi, I'm now also playing with rosjava and eclipse ... if you want import same project it simple. For example create new workspace than right click on the left panel -> import -> android -> browse -> now you must find your android_core folder -> ok ... now you should see all android project in the android_core folder ... if you want select 'android_tutorial_camera' than deselect all and only mark the 'android_tutorial_camera' and 'android_gingerbread_mr1' ... after that it will be OK ... and you can use RosTextView and etc. This it's works for lower android version.

But still can't put into operation for higher version android 'android_honeycomd_mr2' ...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-01-21 20:00:58 -0500

Seen: 174 times

Last updated: Feb 13 '13