Ask Your Question
0

Cannot install any version of ros

asked 2013-01-21 06:43:33 -0500

AlphaOne gravatar image

updated 2013-06-13 07:46:48 -0500

tfoote gravatar image

When I follow the install instructions it says that nothing can be installed be cause dependencies will not be installed. How do I fix this? Using ubuntu 12.04

here is the error I get

Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-groovy-desktop-full : Depends: ros-groovy-ros-tutorials (= 0.3.9-0precise-20121230-1218-+0000) but it is not going to be installed
                           Depends: ros-groovy-nodelet-core (= 1.7.13-0precise-20130104-0044-+0000) but it is not going to be installed
                           Depends: ros-groovy-navigation-tutorials (= 0.1.1-s1357276030~precise) but it is not going to be installed
                           Depends: ros-groovy-geometry-tutorials (= 0.1.3-s1357177371~precise) but it is not going to be installed
                           Depends: ros-groovy-filters (= 1.6.0-s1356885392~precise) but it is not going to be installed
                           Depends: ros-groovy-slam-gmapping (= 1.2.7-s1357273397~precise) but it is not going to be installed
                           Depends: ros-groovy-qt-gui-core (= 0.2.9-0precise-20121230-1132-+0000) but it is not going to be installed
                           Depends: ros-groovy-vision-opencv (= 1.10.0-0precise-20130103-2233-+0000) but it is not going to be installed
                           Depends: ros-groovy-perception-pcl (= 1.0.25-0precise-20130104-0111-+0000) but it is not going to be installed
                           Depends: ros-groovy-rqt-common-plugins (= 0.2.7-0precise-20130104-0046-+0000) but it is not going to be installed
                           Depends: ros-groovy-actionlib (= 1.9.11-0precise-20130102-2201-+0000) but it is not going to be installed
                           Depends: ros-groovy-image-pipeline (= 1.10.1-0precise-20130104-0139-+0000) but it is not going to be installed
                           Depends: ros-groovy-stage (= 1.6.7-s1357177365~precise) but it is not going to be installed
                           Depends: ros-groovy-rqt-robot-plugins (= 0.2.7-0precise-20130103-2333-+0000) but it is not going to be installed
                           Depends: ros-groovy-image-common (= 1.9.22-0precise-20130103-0000-+0000) but it is not going to be installed
                           Depends: ros-groovy-bond-core (= 1.7.9-0precise-20121230-1144-+0000) but it is not going to be installed
                           Depends: ros-groovy-common-tutorials (= 0.2.3-s1357260899~precise) but it is not going to be installed
                           Depends: ros-groovy-ros-comm (= 1.9.39-0precise-20121230-1434-+0000) but it is not going to be installed
                           Depends: ros-groovy-driver-common (= 1.6.4-0precise-20130104-0045-+0000) but it is not going to be installed
                           Depends: ros-groovy-executive-smach (= 1.2.0-s1357171161~precise) but it is not going to be installed
                           Depends: ros-groovy-dynamic-reconfigure (= 1.5.31-0precise-20130104-0028-+0000) but it is not going to be installed
                           Depends: ros-groovy-image-transport-plugins (= 1.8.15-0precise-20130104-0046-+0000) but it is not going to be installed
                           Depends: ros-groovy-xacro (= 1.6.1-s1356886240~precise) but it is not going to be installed
                           Depends: ros-groovy-robot-model (= 1.9.32-0precise-20130103-0145-+0000) but it is not going to be installed
                           Depends: ros-groovy-visualization-tutorials (= 0.7.3-s1357254450~precise) but it is not going to be installed
                           Depends: ros-groovy-geometry (= 1.9.28-0precise-20130103-0114-+0000) but it is not going to be installed
                           Depends: ros-groovy-documentation (= 1.5.3-s1356885143~precise) but it is not going to be installed
                           Depends: ros-groovy-laser-pipeline (= 1.5.5-s1357268665~precise) but it is not going to be installed
                           Depends: ros-groovy-simulator-gazebo (= 1.7.6-s1357263540~precise) but it is not going ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-01-21 08:45:07 -0500

Hi AlphaOne, welcome to ROS Answers! Is this a fresh Ubuntu 12.04 install? Have you tried to install ROS and interrupted the process somehow? It seems like you may have broken packages in your package manager. Here are some ideas: http://askubuntu.com/questions/167688/how-to-fix-apt-get

edit flag offensive delete link more
1

answered 2013-08-06 18:59:48 -0500

updated 2013-08-06 21:22:09 -0500

I also faced this issue in Ubuntu 12.04, in my opinion both ROS fuerte and ROS groovy have installation issues for 3.5 version of kernel, but works fine with 3.2. Check your kernel version with uname -a in the terminal window and if it is 3.5, then you may need to reinstall your OS, go for Ubuntu 12.04 release, later version (viz. 12.04.2 etc) have a higher kernel.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-01-21 06:43:33 -0500

Seen: 368 times

Last updated: Aug 06 '13