Ask Your Question
0

vmware subscriber multiplemachines problem

asked 2012-12-31 06:45:21 -0500

hej gravatar image

updated 2014-04-20 14:09:21 -0500

ngrennan gravatar image

Hello, I try to connect my Ubuntu system [a] to a virtual Ubuntu machine (VMware)[b] by network. It seems to work. I can ping and ssh from one to the other machine. Furthermore when I start a roscore on [a] I can run for example "rosrun rospy_tutorial listener.py" on machine [b] and it finds the roscore. If I start the talker on [a] I can see on [b] the topic "/chatter" and the node "/talker_3586_1356978819462".

But if I run the listener now on [b] (still with the roscore of [a]) it doesn't hear anything. I have no clue, where the problem is. Maybe someone can help me with that?

Some things that I have already tried: - Start a talker and listener only on machine [a] works. - Start a talker and listener only on machine [b] (with core of [a]) works. - Previously I had the Ubuntu system [a] also on a virtual machine and this example worked with both virtual machines [a] and [b] running in windows.

Best Jonathan

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-01-02 13:09:48 -0500

tfoote gravatar image

ROS relies on bidirectional communications. Make sure you work all the way through the Network Setup Guide This sounds like you have hostnames which cannot lookup fully on both machines.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-12-31 06:45:21 -0500

Seen: 224 times

Last updated: Jan 02 '13