Ask Your Question
0

Catkin-izing OpenCV-based package

asked 2012-12-10 14:57:03 -0500

Dave Coleman gravatar image

updated 2012-12-10 14:57:30 -0500

I converted my package that relies on OpenCV to catkin but I am getting lots of OpenCV errors. Is there somewhere that documents the required OpenCV changes to port to the new version?

catkin_make is outputting these errors.

This is my CMakeLists.txt and this is the Github package repo.

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-12-11 17:04:55 -0500

tfoote gravatar image

You need opencv and all the other elements in your CATKIN_DEPENDS element also in your find_package call. CATKIN_DEPENDS only exposes those elements to your downstream packages, not your own package.

edit flag offensive delete link more

Comments

perfect, thanks! each dependency sure requires a lot of duplication in the package.xml and CMakeLists.txt

Dave Coleman gravatar image Dave Coleman  ( 2012-12-12 11:53:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2012-12-10 14:57:03 -0500

Seen: 707 times

Last updated: Dec 11 '12