Ask Your Question
2

rviz black screen [closed]

asked 2012-11-25 09:44:44 -0500

viovio gravatar image

updated 2013-03-30 09:48:53 -0500

Hello together,

when I try to start rviz in 60% of the tries the rviz screen just stays black. Starting with the same parameters! When Rviz on time stayed black the chance is smaller that the next try works. Sometimes there a 20 tries with only black screens. After doing a while different stuff the chance get higher that rviz works agagin. I dont have any clue which factor influences rviz to work or not to work.

Edit: This was the problem: I suggest the problem could be that I run my ROS-Enviroment on a ubuntu in the vmware-player. Maybe the virtual graphic-card of the vamware-image doesnt fit with rviz.

Many thanks in advance Dominik

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by viovio
close date 2013-03-30 09:49:23

Comments

I get the same thing running Ubuntu 12.04 64-bit natively with ATI graphics card. I have not seen this on any laptops/desktops with Nvidia cards.

Thomas D gravatar image Thomas D  ( 2012-11-25 13:22:11 -0500 )edit

Which ROS release are you using? I had similar problems on Electric, but haven't experienced it at all since installing Fuerte. I'm also running Ubuntu 12.04 64-bit natively, with an ATI graphics card.

damjan gravatar image damjan  ( 2012-11-25 23:02:16 -0500 )edit

Im using also Ubuntu 12.04 64-bit natively with an ATI graphics card. I use Fuerte.

viovio gravatar image viovio  ( 2012-11-25 23:56:20 -0500 )edit

So, you are running Fuerte on a Ubuntu that's running inside a vmware-player, which is running on a native Ubuntu? This could be a problem: http://answers.ros.org/question/35172/does-rviz-run-properly-on-a-virtual-machine-i-followed-all-instructions-but-the-display-is-just-a-blank-screen/

damjan gravatar image damjan  ( 2012-11-26 05:33:42 -0500 )edit

But there seems to be no solution, except installing ubuntu on a single partition. This would be pretty uncomfortable, especially using visual studio for programming. Are there more proposals? Meanwhile I try to follow the Answer.

viovio gravatar image viovio  ( 2012-12-01 03:23:19 -0500 )edit

Did changing OGRE_RTT_MODE (as suggested in the answer by @stephanem) help? For me, deleting the whole ~/.rviz directory prior to starting rviz would sometimes help.

damjan gravatar image damjan  ( 2012-12-05 01:46:34 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-11-25 22:37:38 -0500

Have you tried changing http://www.ros.org/wiki/rviz/Troubleshooting#Segfault_during_startup (OGRE_RTT_MODE) to something else than "PBuffer" ?

When I had some problems with rviz, I saw that this parameter may influence the behavior of rviz...

edit flag offensive delete link more

Comments

link for the lazy

eric-wieser gravatar image eric-wieser  ( 2016-04-02 14:37:21 -0500 )edit

Question Tools

Stats

Asked: 2012-11-25 09:44:44 -0500

Seen: 1,954 times

Last updated: Mar 30 '13