Ask Your Question
0

error to rosrun

asked 2012-11-18 01:21:59 -0500

Hi,i have an error to execute re_comm package and actually all packages in Roboearth Stack

i installed it in /home/marwa/ros and rosmake it

and i linked it with RoS

and bedin to roscore and run

but when typing : rosrun re_comm run

it makes error

rosrun] Couldn't find executable named run below /home/marwa/ros/stacks/roboearth/re_comm

the result of rosmake re_comm :

marwa@marwa-Inspiron-1564:~$ rosmake re_comm

[ rosmake ] rosmake starting...                                                 
[ rosmake ] Packages requested are: ['re_comm']                                 
[ rosmake ] Logging to directory /home/marwa/.ros/rosmake/rosmake_output-20121118-143439
[ rosmake ] Expanded args ['re_comm'] to:
['re_comm']                           
[rosmake-0] Starting >>> roslib [ make ]                                        
[rosmake-1] Starting >>> roslang [ make ]                                       
[rosmake-2] Starting >>> rospack [ make ]                                       
[rosmake-3] Starting >>> std_msgs [ make ]                                      
[rosmake-0] Finished <<< roslib  No Makefile in package roslib                  
[rosmake-1] Finished <<< roslang  No Makefile in package roslang                
[rosmake-0] Starting >>> geometry_msgs [ make ]                                 
[rosmake-1] Starting >>> roscpp [ make ]                                        
[rosmake-3] Finished <<< std_msgs  No Makefile in package std_msgs              
[rosmake-2] Finished <<< rospack  No Makefile in package rospack                
[rosmake-2] Starting >>> thea [ make ]                                          
[rosmake-3] Starting >>> rosbuild [ make ]                                      
[rosmake-1] Finished <<< roscpp  No Makefile in package roscpp                  
[rosmake-1] Starting >>> rosjava_jni [ make ]                                   
[rosmake-0] Finished <<< geometry_msgs  No Makefile in package geometry_msgs    
[rosmake-0] Starting >>> re_msgs [ make ]                                       
[rosmake-3] Finished <<< rosbuild  No Makefile in package rosbuild              
[rosmake-3] Starting >>> rosprolog [ make ]                                     
[rosmake-1] Finished <<< rosjava_jni ROS_NOBUILD in package rosjava_jni         
[rosmake-1] Starting >>> jpl [ make ]                                           
[ rosmake ] All 9 linesthea: 2.4 sec ] [ re_msgs: ... [ 4 Active 8/50 Complete ]
{-------------------------------------------------------------------------------
  cd jpl && autoconf
  sed 's/-cc-options\,//' jpl/configure > jpl/configure.sed; mv jpl/configure.sed jpl/configure; chmod +x jpl/configure
  if test -e /usr/lib/libswipl.so; then sed 's/-lpl/-lswipl/' jpl/configure > jpl/configure.sed; mv jpl/configure.sed jpl/configure; chmod +x jpl/configure; fi
  cd jpl && ./configure
  checking for swi-prolog... no
  checking for swipl... no
  checking for pl... no
  configure: error: "Cannot find SWI-Prolog. SWI-Prolog must be installed first"
-------------------------------------------------------------------------------}
[ rosmake ] Output from build of package jpl written to:
[ rosmake ]    /home/marwa/.ros/rosmake/rosmake_output-20121118-143439/jpl/build_output.log
[rosmake-1] Finished <<< jpl [FAIL] [ 2.43 seconds ]                            
[ rosmake ] Halting due to failure in package jpl. 
[ rosmake ] Waiting for other threads to complete.
[rosmake-2] Finished <<< thea [PASS] [ 3.41 seconds ]                           
[rosmake-3] Finished <<< rosprolog [PASS] [ 3.43 seconds ]                      
[rosmake-0] Finished <<< re_msgs [PASS] [ 4.96 seconds ]                        
[ rosmake ] Results:                                                            
[ rosmake ] Built 12 packages with 1 failures.                                  
[ rosmake ] Summary output to directory                                         
[ rosmake ] /home/marwa/.ros/rosmake/rosmake_output-20121118-14343

My bash file also :

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar ...
(more)
edit retag flag offensive close merge delete

Comments

@tbh can u help us in it plz ?

RiskTeam gravatar imageRiskTeam ( 2012-11-18 01:23:44 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2012-11-18 05:18:55 -0500

The error message indicates that

configure: error: "Cannot find SWI-Prolog. SWI-Prolog must be installed first"

That means you didn't install swi-prolog, after running

sudo apt-get install swi-prolog

rosmake re_comm again.

edit flag offensive delete link more

Comments

5

json_prolog is part of the knowrob stack. I would suggest to not install it from souce anyway but with sudo apt-get install ros-fuerte-knowrob. That will pull in all required dependencies, including swi-prolog.

Lorenz gravatar imageLorenz ( 2012-11-18 08:51:20 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-11-18 01:21:59 -0500

Seen: 243 times

Last updated: Nov 18 '12