Ask Your Question
0

turtlebot roomba dashboard

asked 2012-10-30 06:41:24 -0600

paetti88 gravatar image

updated 2012-11-07 04:49:35 -0600

solved :) .. the launchfile posted by Lorenz works for Turtlebot Roomba Cleaner (EU) .. much thx for this one

ok this is the launchfile which is working(ubuntu 11.10, electric, roomba) but i cant use dashboard und workstaion

<launch>
  <node name="turtlebot_node" type="turtlebot_node.py" pkg="turtlebot_node">
    <rosparam>
      port: /dev/ttyUSB0
      publish_tf: True
      robot:type: roomba
      has_gyro: False

     </rosparam>
  </node>
</launch>

so i tryed to use the launchfiel from lorenz but i get the error:

Error reading from SCI Port. No Data.

Do i have to change something else in case of using a Roomba.

i tested it again without the argument args="--respawnable" i updated the output of roslaunch turtlebot_bringup minimal2.launch but as u can see this launchfile has got the problem

[ERROR] [WallTime: 1352212747.089788] Failed to contact device with error: [Error reading from SCI port. No data.]. Please check that the Create is powered on and that the connector is plugged into the Create. the simple one still did this job.

Any other advices? :)

edit

tryed it again but now using fuerte, but nothing changed, the problem Error reading from SCI port. No data. is still there. If i use minimal.launch and the launchfiel by lorenz ... the minimal file posted above still works.

edit

ok i tried testing rostopic echo /odom after starting your launchfile (the error is printing) but der was no output of this instruction (waiting for 10 min)

ok i thought maybe it would be nice for your if u get the output of this instruction by the minimal fiel above. looks like this

 
turtlebot@turtlebot-R002:/opt/ros/electric/stacks/turtlebot/turtlebot_bringup$ roslaunch turtlebot_bringup minimal2.launch 
... logging to /home/turtlebot/.ros/log/af6a9606-281f-11e2-bacf-0008ca665690/roslaunch-turtlebot-R002-27836.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://192.168.0.156:48679/

SUMMARY
========

PARAMETERS
 * /use_sim_time
 * /diagnostic_aggregator/analyzers/sensors/path
 * /robot/name
 * /diagnostic_aggregator/analyzers/nodes/timeout
 * /diagnostic_aggregator/analyzers/mode/timeout
 * /diagnostic_aggregator/analyzers/sensors/timeout
 * /diagnostic_aggregator/analyzers/power/type
 * /diagnostic_aggregator/analyzers/power/timeout
 * /turtlebot_node/has_gyro
 * /diagnostic_aggregator/analyzers/mode/type
 * /turtlebot_laptop_battery/acpi_path
 * /robot_state_publisher/publish_frequency
 * /diagnostic_aggregator/analyzers/digital_io/path
 * /turtlebot_node/port
 * /turtlebot_node/robot:type
 * /diagnostic_aggregator/analyzers/digital_io/timeout
 * /diagnostic_aggregator/analyzers/nodes/path
 * /rosdistro
 * /robot_description
 * /diagnostic_aggregator/base_path
 * /app_manager/interface_master
 * /diagnostic_aggregator/analyzers/sensors/type
 * /diagnostic_aggregator/analyzers/digital_io/startswith
 * /diagnostic_aggregator/analyzers/power/path
 * /diagnostic_aggregator/analyzers/mode/path
 * /diagnostic_aggregator/analyzers/digital_io/type
 * /diagnostic_aggregator/analyzers/mode/startswith
 * /rosversion
 * /diagnostic_aggregator/pub_rate
 * /turtlebot_node/publish_tf
 * /diagnostic_aggregator/analyzers/sensors/startswith
 * /diagnostic_aggregator/analyzers/power/startswith
 * /robot/type
 * /diagnostic_aggregator/analyzers/nodes/type
 * /diagnostic_aggregator/analyzers/nodes/contains

NODES
  /
    appmaster (app_manager/appmaster)
    app_manager (app_manager/app_manager)
    turtlebot_node (turtlebot_node/turtlebot_node.py)
    turtlebot_laptop_battery (turtlebot_node/laptop_battery.py)
    robot_state_publisher (robot_state_publisher/state_publisher)
    diagnostic_aggregator (diagnostic_aggregator/aggregator_node)

auto-starting new master
process[master]: started with pid [27853]
ROS_MASTER_URI=http://192.168.0.156:11311

setting /run_id to af6a9606-281f-11e2-bacf-0008ca665690
process[rosout-1]: started with pid [27866]
started core service [/rosout]
process[appmaster-2]: started with pid [27879]
process[app_manager-3]: started with pid [27880]
process[turtlebot_node-4]: started with pid [27881]
process[turtlebot_laptop_battery-5]: started with pid [27882]
process[robot_state_publisher-6 ...
(more)
edit retag flag offensive close merge delete

Comments

Please do not delete your original post since this would make any answers look wrong. Is the message printed multiple times or just one? Did you verify that the robot is actually really not working? Maybe the turtlebot_node recovers and connects although it prints the error once.

Lorenz gravatar imageLorenz ( 2012-11-01 06:44:09 -0600 )edit

Also, I would try removing the args="--respawnable" since it is the only difference between your original launch file and the one I posted.

Lorenz gravatar imageLorenz ( 2012-11-01 06:45:08 -0600 )edit

It is hard to help if you do not answer my questions and provide additional information. Is the message printed multiple times or just once? How did you verify that the robot is not working? Try rostopic echo /odom. Did you try removing the --respawnable arg?

Lorenz gravatar imageLorenz ( 2012-11-06 05:49:59 -0600 )edit

i did answer on your question and yes i tested it with out args="--respawnable" and id die update the output .. as u can see the error is printet twice ... then i stop the script becouse i thing the output is long enought .. means .. yes it will be printed several times.

paetti88 gravatar imagepaetti88 ( 2012-11-07 02:38:15 -0600 )edit

Thanks for making that explicit. Maybe I missed where you pointed that out before. I think I found the problem: a typo in the launch file I put in my answer. I copy-pasted the turtlebot_node section from your question and you wrote robot:type, not robot_type. I'll update my answer.

Lorenz gravatar imageLorenz ( 2012-11-07 03:28:01 -0600 )edit

wow think this works now for me ... accepted this as correkt ... much much thx for your effort :)

paetti88 gravatar imagepaetti88 ( 2012-11-07 03:45:33 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-10-30 06:51:03 -0600

Lorenz gravatar image

updated 2012-11-07 03:34:35 -0600

The diagnostics node is missing. The above launch file only brings up the basic turtlebot driver. On the iCreate based turtlebot, the robot is normally brought up by the launch file turtlebot_bringup/minimal.launch. For the roomba, you need to replace it with the following launch file to get rviz visualization and the dashboard working:

<launch>
  <param name="/use_sim_time" value="false"/>

  <arg name="urdf_file" default="$(find xacro)/xacro.py '$(find turtlebot_description)/robots/turtlebot.urdf.xacro'" />
  <param name="robot_description" command="$(arg urdf_file)" />

  <param name="robot/name" value="$(optenv ROBOT turtlebot)"/>
  <param name="robot/type" value="turtlebot"/>

  <include file="$(find turtlebot_bringup)/app_manager.launch" />

  <!-- Turtlebot Driver -->
  <node pkg="turtlebot_node" type="turtlebot_node.py" name="turtlebot_node" output="screen" respawn="true" args="--respawnable">
    <rosparam>
      port: /dev/ttyUSB0
      publish_tf: True
      robot_type: roomba
      has_gyro: False
    </rosparam>
  </node>

  <!-- Turtlebot Laptop Battery Diagnostics -->
  <node pkg="turtlebot_node" type="laptop_battery.py" name="turtlebot_laptop_battery">
        <param name="acpi_path" type="string" value="/proc/acpi/battery/BAT0" />
  </node>

  <node pkg="robot_state_publisher" type="state_publisher" name="robot_state_publisher" output="screen">
    <param name="publish_frequency" type="double" value="5.0" />
    <!--param name="tf_prefix" type="string" value="" /-->
  </node>

  <node pkg="diagnostic_aggregator" type="aggregator_node" name="diagnostic_aggregator" >
    <!-- Load the file you made above -->
    <rosparam command="load" file="$(find turtlebot_bringup)/config/diagnostics.yaml" />
  </node>
</launch>

Edit: Regarding your question where you can get roomba related files. The roomba is not officially supported by Willow Garage and turtlebot.eu is unfortunately not providing support either. It took me quite a while to create the patches for turtlebot_node to make it work. But apart from the basic launch file, no changes should be required now so you should be able to use all turtlebot related resources now.

edit flag offensive delete link more
0

answered 2012-10-30 07:30:31 -0600

paetti88 gravatar image

much thx i am very happy to get this file .. where can i find roomba realated files?

but i got problems with this launchfile if i use the one from u get the error Error readiong from sci port no data. if i use the one posted by me i am not getting this error ut i cant use dashbord.

So do i have to change something else?

edit flag offensive delete link more

Comments

Please do not create answers for discussion or subsequent questions. Instead, please either edit your original post or use the comment functionality. This is not a forum.

Lorenz gravatar imageLorenz ( 2012-10-31 02:44:56 -0600 )edit

ok i will but why there is no comment function to the first answer?

paetti88 gravatar imagepaetti88 ( 2012-11-01 04:07:16 -0600 )edit

You can comment posts from other people only when you have enough karma. But you can always edit your own posts. Please edit your original question and add the exact error output. Are you using exactly the launch file I posted? The definition of the turtlebot node should be identical, i.e. work.

Lorenz gravatar imageLorenz ( 2012-11-01 04:56:51 -0600 )edit

jea i c&p'ed it and then tryed to launch ...

paetti88 gravatar imagepaetti88 ( 2012-11-01 05:43:23 -0600 )edit

Please copy/paste the complete output of roslaunch.

Lorenz gravatar imageLorenz ( 2012-11-01 05:53:04 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-30 06:41:24 -0600

Seen: 2,029 times

Last updated: Nov 07 '12