Ask Your Question
1

problem with installation of gradlew

asked 2012-10-26 03:26:55 -0500

iran gravatar image

updated 2012-10-26 04:24:32 -0500

Hi

I am trying to install gradlew through this command with the help of [http://docs.rosjava.googlecode.com/hg/rosjava_core/html/building.html]

I got this error "package motion_planning_msgs does not exist"

does anyone have any idea how should I solve this problem

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2012-10-26 04:43:03 -0500

updated 2012-10-29 02:58:30 -0500

Hi Iran,

I guess you are using ROS Fuerte, right? The package that was called motion_planning_msgs in Electric has been merged into arm_navigation_msgs in Fuerte, so it doesn't exist any more. My guess is that you still have some artifacts from an Electric build lying around somewhere. Can you delete the directories ~/.m2 and ~/.ros/rosjava/ and try again?

If that doesn't help, check that your environment variables are set up correctly. In particular, check that the ROS_PACKAGE_PATH is correct (see "Environment setup" in the ROS installation instructions).

$ echo $ROS_PACKAGE_PATH

should say something like this (first some place(s) under your home dir where you put your own packages, then /opt/ros/fuerte stuff, no electric):

/home/martin/ros-fuerte:/opt/ros/fuerte/share:/opt/ros/fuerte/stacks

UPDATE (solution): For later reference: In private communication with Iran, it turned out that the problem's cause was that an older revision of rosjava_core was built with electric, then rosjava_core was updated to the current tip and compiled with Fuerte. Removing the rosjava_core directory and cloning it fresh solved the problem.

edit flag offensive delete link more

Comments

Yes, I have ROS electric installed in my computer. but, as you suggested, I delete ~/.m2 and ~/.ros/rosjava/ and then I try ./gradlew install. Again I have the same error. Also, my environment variable setup which was correct. any other suggestion? what about deleting the whole ROS electric?

iran gravatar image iran  ( 2012-10-28 04:29:37 -0500 )edit
0

answered 2012-10-26 05:28:00 -0500

iran gravatar image

Hi Martin,

I made mistake in removing! instead of removing ~/.ros/rosjava. I delete the whole folder ~/.ros

First, how should I recover the whole dependency which I removed?

Thanks, Iran

edit flag offensive delete link more

Comments

The .ros directory doesn't contain anything terribly important (log files, rviz configs...); everything should be regenerated automatically, so don't worry.

P.S.: When responding to an answer, you shouldn't post another answer, but use the "post a comment" button below that answer instead.

Martin Günther gravatar image Martin Günther  ( 2012-10-26 07:06:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-10-26 03:26:55 -0500

Seen: 202 times

Last updated: Oct 29 '12