Kinect extrinsic calibration problem: no output cache bag [closed]

asked 2012-10-12 06:46:07 -0500

frankpablo gravatar image


I am working with ROS Fuerte, under Ubuntu 12.04 and I am trying to calibrate the Kinect IR camera with its integrated rgb camera. I have calibrated the intrinsics of each camera successfully but can't complete the extrinsic calibration. After going through the first sections of the openni_launch/Tutorials/ExtrinsicCalibration tutorial, I come up to the section where I run the following command (with the correct measurements for my checkerboard):

roslaunch camera_pose_calibration calibrate_2_camera.launch camera1_ns:=/camera/rgb_bag camera2_ns:=/camera/ir checker_rows:=6 checker_cols:=8 checker_size:=0.0262

and after playing the recorded rgb.bag file as instructed in the tutorial, both images (camera/rgb_bag and camera/ir) in the aggregated image viewer are visible and have their bars fill completely, but nothing happens after that.

the tutorial states that:

The calibrator should find the checkerboard and successfully run the optimization. [...] The tf publisher caches the transform to whatever path you gave it with the cache_file argument.

the path I gave to place the cache_bag is :


but even though the path exists, the kinect_extrinsics_cache.bag file is not written.

this other answer here suggests:

To debug your problem, make sure you have rxconsole open when you're running the calibration, and see what kind of feedback you get. For further questions about the camera_pose_calibration, please start a new topic.

rxconsole displays no obvious errors or warnings but still no extrinsics are written.

...Another point is that to be able to run this tutorial I had to obtain the "fixed" camera_pose stack in here as suggested here.

Am I missing something?

Thank you in advance

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-08-31 20:03:41.820178



Hello, currently I am having same problem. Could you please tell me if you found error ? Or tell me what you used instead please ?

CHz gravatar image CHz  ( 2013-04-09 08:29:41 -0500 )edit

I'm getting stuck at finding the checkerboard. How did you guys get past the "Timed out waiting for a checkerboard"?

astaranowicz gravatar image astaranowicz  ( 2013-05-22 13:45:26 -0500 )edit

Just do it in this order; -- roscore -- rosparam set /use_sim_time false -- roslaunch Desktop/ExtrinsicCalibration/ExtrinsicCalibration.launch -- rosbag record --limit=300 -O Desktop/ExtrinsicCalibration/rgb.bag /camera/rgb/image_rect /camera/rgb/camera_info -- CTRL-C -camera_launch

CHz gravatar image CHz  ( 2013-05-23 23:39:55 -0500 )edit

rosparam set /use_sim_time true -- roslaunch Desktop/ExtrinsicCalibration/ExtrinsicCalibration.launch -- rosrun contrast contrast_augmenter -- rosbag play Desktop/ExtrinsicCalibration/rgb.bag --clock

CHz gravatar image CHz  ( 2013-05-23 23:40:18 -0500 )edit

-- roslaunch camera_pose_calibration calibrate_2_camera.launch camera1_ns:=/camera/rgb_bag camera2_ns:=/camera/ir_augmented checker_rows:=6 checker_cols:=8 checker_size:=0.035 -- rosbag play Desktop/ExtrinsicCalibration/rgb.bag --clock /camera/rgb/camera_info:=/camera/rgb_bag/camera_info /camera/rgb

CHz gravatar image CHz  ( 2013-05-23 23:40:38 -0500 )edit

Still doesn't work. Still says timed out waiting for checkerboard. These are the same directions as on: with the exception of the contrast augmentor.

astaranowicz gravatar image astaranowicz  ( 2013-05-30 09:37:03 -0500 )edit

do you close projector ? It should not project anything on IR image. This is what I remember.

CHz gravatar image CHz  ( 2013-05-30 09:52:52 -0500 )edit

Yes, the projector is covered. I have done the steps a few times. Still the same error. Just weird that I can calibrate each camera separately (the checkerboard is found). Just trying to do this, it says theres no checkerboard.

astaranowicz gravatar image astaranowicz  ( 2013-05-30 10:17:19 -0500 )edit