Ask Your Question
1

installation RoboEarth packages

asked 2012-10-11 23:37:24 -0600

salma gravatar image

updated 2012-10-12 06:02:44 -0600

Hi, In this link http://www.ros.org/wiki/roboearth i try to install roboearth packages re_comm ,re_kinect_object_detector,....etc in my fuerte

i begin by typing command :

sudo apt-get install python-rosinstall

it begin ti install normally then i begin typing command :

$ rosinstall ~/ros /opt/ros/fuerte 'http://www.ros.org/wiki/roboearth?action=AttachFile&do=get&target=roboearth.rosinstall'

it appear

rosinstall operating on /home/salma/ros from specifications in rosinstall files  /opt/ros/fuerte, http://www.ros.org/wiki/roboearth?action=AttachFile&do=get&target=roboearth.rosinstall
(Over-)Writing /home/salma/ros/.rosinstall
rosinstall update complete.


Now, type 'source /home/salma/ros/setup.bash' to set up your environment.
Add that to the bottom of your ~/.bashrc to set it up every time.

If you are not using bash please see http://www.ros.org/wiki/rosinstall/NonBashShells 
salma@salma-G31M-S2L:~$ [sudo] password for salma: 
[sudo]: command not found
salma@salma-G31M-S2L:~$ Reading package lists... Done
Reading: command not found
salma@salma-G31M-S2L:~$ Building dependency tree       
Building: command not found
salma@salma-G31M-S2L:~$ Reading state information... Done
Reading: command not found
salma@salma-G31M-S2L:~$ The following extra packages will be installed:
No command 'The' found, did you mean:
 Command 'the' from package 'the' (universe)
The: command not found
salma@salma-G31M-S2L:~$   bzr git git-core git-man liberror-perl mercurial mercurial-common
bzr: ERROR: unknown command "git"
salma@salma-G31M-S2L:~$   python-bzrlib python-configobj python-vcstools
python-bzrlib: command not found
salma@salma-G31M-S2L:~$ Suggested packages:
Suggested: command not found
salma@salma-G31M-S2L:~$   bzr-doc bzr-gtk bzr-svn python-bzrlib.tests bzrtools git-daemon-run
bzr-doc: command not found
salma@salma-G31M-S2L:~$   git-daemon-sysvinit git-doc git-el git-arch git-cvs git-svn git-email
git-daemon-sysvinit: command not found
salma@salma-G31M-S2L:~$   git-gui gitk gitweb qct vim emacs kdiff3 tkdiff meld xxdiff python-mysqldb
git-gui: command not found
salma@salma-G31M-S2L:~$   python-kerberos python-gpgme python-bzrlib-dbg
python-kerberos: command not found
salma@salma-G31M-S2L:~$ The following NEW packages will be installed:
No command 'The' found, did you mean:
 Command 'the' from package 'the' (universe)
The: command not found
salma@salma-G31M-S2L:~$   bzr git git-core git-man liberror-perl mercurial mercurial-common
bzr: ERROR: unknown command "git"
salma@salma-G31M-S2L:~$   python-bzrlib python-configobj python-rosinstall python-vcstools
python-bzrlib: command not found
salma@salma-G31M-S2L:~$ 0 upgraded, 11 newly installed, 0 to remove and 143 not upgraded.
0: command not found
salma@salma-G31M-S2L:~$ Need to get 10.7 MB of archives.
No command 'Need' found, did you mean:
 Command 'seed' from package 'seed' (universe)
Need: command not found
salma@salma-G31M-S2L:~$ After this operation, 32.4 MB of additional disk space will be used.
After: command not found
salma@salma-G31M-S2L:~$ Do you want to continue [Y/n]? y
Do: command not found
salma@salma-G31M-S2L:~$ Get:1 http://packages.ros.org/ros/ubuntu/ precise/main python-vcstools all 0.1.22-1 [20.0 kB]
Get:1: command not found

then the stack become in my Home not in my ROS/furete/stacks to deal with !


salma@salma-G31M-S2L:~$ ls ~/ros
pkgs  setup.bash  setup.sh  setup.zsh  stacks
edit retag flag offensive close merge delete

Comments

salma if you check the errors, you do not have git installed (probably bzr is also not installed)

Arkapravo gravatar imageArkapravo ( 2012-10-12 11:06:14 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2012-10-11 23:57:25 -0600

KruseT gravatar image

You need to run

source ~/ros/setup.bash

in the same terminal before running rosmake roboearth. It is not clear whether you did so. If this still fails, paste the result of

echo $ROS_PACKAGE_PATH

into your question, please.

edit flag offensive delete link more

Comments

it doesn't work

the result of echo $ROS_PACKAGE_PATH is : /opt/ros/fuerte/share:/opt/ros/fuerte/stacks

salma gravatar imagesalma ( 2012-10-12 00:24:45 -0600 )edit

This indicates that sourcing setup.bash did not work correctly. Did you get any error messages, either in the rosinstall command or when executing the source command?

Lorenz gravatar imageLorenz ( 2012-10-12 05:06:54 -0600 )edit

now when i write $ source ~/ros/setup.bash bash: /home/salma/ros/setup.bash: No such file or directory

i found : bash: /home/salma/ros/setup.bash: No such file or directory

salma gravatar imagesalma ( 2012-10-12 05:14:45 -0600 )edit

Did the rosinstall command throw an errror?

Lorenz gravatar imageLorenz ( 2012-10-12 05:17:08 -0600 )edit

no and stack installed but in Home

salma gravatar imagesalma ( 2012-10-12 05:19:45 -0600 )edit

Can you please edit your original question and add the exact output of the command? See http://ros.org/wiki/Support Something seems to be messed up in your system and we need to find out what. Also, what's the output of ls ~/ros?

Lorenz gravatar imageLorenz ( 2012-10-12 05:23:04 -0600 )edit

ok i did :)

salma gravatar imagesalma ( 2012-10-12 05:42:57 -0600 )edit

I cannot see the output of ls ~/ros.

Lorenz gravatar imageLorenz ( 2012-10-12 05:44:05 -0600 )edit
0

answered 2012-10-12 05:35:40 -0600

tbh gravatar image

Going off of combined info from this question...

Perhaps the rosinstall documentation might help. You can install roboearth wherever you want to, but you specified ~/ros as the destination in your command. In the installation instructions you're following, the next line after the code box specifies what the paths are so you can change them if you want. You can also type 'rosinstall -h' to see the rosinstall help info.

The program wasn't quite done on the second picture you posted on the other question. But if it ran without errors, it should have created a setup.bash file for roboearth somewhere. You need to find that file and source it. It should be in ~/ros but maybe it's in a different directory like ~/ros/stacks or ~/ros/stacks/roboearth

If there were errors when rosinstall-ing roboearth, please edit this question to include them now that rosinstall is installed so we can be of more help.

edit flag offensive delete link more

Comments

@tbh After i intalled roboearth and what was said in the installation instructions, every time i open a terminal before i could write anything y get bash: /bin/sed: Argument list too long bash: /bin/sed: Argument list too long bash: /usr/bin/env: Argument list too long after a while i found out it was due to the .bashrc file because when it run source /opt/ros/fuerte/setup.bash it got stuck. Now my ROS does not work, when i put echo $ROS_PACKAGE-PATH i dont get the path i get a blank space and can call anything related to ROS. Do you know why this happens and what is wrong with the setup.bash file, thanks really apreciate it

ctguell gravatar imagectguell ( 2013-08-27 06:29:00 -0600 )edit

Hi @ctguell. Ros Answers is more of a question/answer site for specific questions than a forum on general topics. So you did right in asking [your question](http://answers.ros.org/question/75001/problems-after-installing-roboearth/) in a new thread rather than here.

tbh gravatar imagetbh ( 2013-08-27 08:38:01 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-11 23:37:24 -0600

Seen: 418 times

Last updated: Oct 12 '12