Ask Your Question
0

Error with pointcloud_to_laserscan and rviz [closed]

asked 2012-10-09 23:27:16 -0500

g.aterido gravatar image

updated 2012-10-09 23:28:24 -0500

Hello

I'm trying to convert a point cloud to a fake laser scan and then visualize it with rviz. For doing that, first I use the pointcloud_to_laserscan stack. I think I have no problem with this part because with rostopic echo I can see a list of points of the laser scan, and all seems right.

The problem starts when I try to visualize this fake laser with rviz. I add a new LaserScan display and I put the topic of the laser scan converted. When I do that, the display status changes to "Error" and I get this warning message on the console:

[ WARN] [1349860717.340263739, 12012.394000000]: MessageFilter [target=/map ]: Dropped 100,00% of messages so far. Please turn the [ros.rviz.message_notifier] rosconsole logger to DEBUG for more information.

Does anyone know why I get this error?

For more detail, there's how I convert the point_cloud to a fake laser scan:

  <!-- openni_manager -->
  <node pkg="nodelet" type="nodelet" name="openni_manager" output="screen" respawn="true" args="manager"/> 

     <!-- fake laser -->
  <node pkg="nodelet" type="nodelet" name="kinect_laser" args="load pointcloud_to_laserscan/CloudToScan openni_manager">
    <param name="output_frame_id" value="/openni_depth_frame"/>
    <param name="range_max" value="10.0"/>
    <param name="range_min" value="0.4"/>
    <param name="angle_max" value="0.383972435"/>
    <param name="angle_min" value="-0.383972435"/>
    <remap from="cloud" to="/tof_camera/depth/points"/>
    <remap from="scan" to="tof_camera/fake_laser"/>
  </node>

I'm in Ubuntu 12.04 and ROS Fuerte. Thanks in advance. Regards.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by g.aterido
close date 2012-11-28 21:53:30

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-10-10 00:16:24 -0500

Lorenz gravatar image

What's your target frame in rviz? I guess it's map and you don't have map in your TF tree. Try changing it, for instance to openni_detph_frame.

edit flag offensive delete link more

Comments

Wow, I'm stupid... I've added the openni_detph_frame to my TF tree and now all works. I forgot to add it and that was the problem. Thank you for your answer, and sorry for this stupid question ;)

g.aterido gravatar imageg.aterido ( 2012-10-10 00:28:36 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2012-10-09 23:27:16 -0500

Seen: 1,590 times

Last updated: Oct 10 '12