Ask Your Question
2

[SOLVED] rosinstall on OSX Mountain Lion [closed]

asked 2012-10-06 11:49:02 -0500

durka42 gravatar image

updated 2012-10-08 07:47:01 -0500

So I'm trying to install Fuerte using Homebrew as per these instructions. I got as far as rosinstall, but although pip seems to have successfully installed rosinstall, it's not on my PATH. My PATH is:

  • /usr/local/bin
  • /usr/local/lib/wxPython/bin
  • /usr/bin
  • /bin
  • /usr/sbin
  • /sbin
  • /opt/X11/bin
  • /usr/texbin

I found some scripts like rosinstall_cmd.py in /usr/local/lib/python2.7/site-packages/rosinstall; is one of those supposed to be symlinked into /usr/local/bin perhaps?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Kevin
close date 2012-10-08 15:24:19

Comments

Sorry ... can you identify exactly what step you got to before the instructions failed?? Your path seems fine and I assume you got to step 1.2.2 where you successfully did: easy_install pip and setuptools? How much farther did you get?

Kevin gravatar imageKevin ( 2012-10-07 08:32:32 -0500 )edit

Sorry again ... I focused a little too much on pip. I have rosinstall (python script) located in /usr/local/bin and it is not a symlink but an actual script. What are your .bashrc and .profiles? what is the output of env?

Kevin gravatar imageKevin ( 2012-10-07 08:36:27 -0500 )edit

I also have in my env: PYTHONPATH=/usr/local/lib/python2.7/site-packages ... do you have something similar?

Kevin gravatar imageKevin ( 2012-10-07 08:37:16 -0500 )edit
1

Hi Kevin. I have done everything up through step 1.2.4, and I can't do step 1.3 because I don't seem to have a rosinstall script anywhere. My PYTHONPATH does include that directory. Here is env: http://pastie.org/5019902

durka42 gravatar imagedurka42 ( 2012-10-08 07:41:31 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-10-08 07:55:37 -0500

durka42 gravatar image

SOLVED. I found the scripts rosinstall, rosws, etc. They were installed to /usr/local/share/python.

edit flag offensive delete link more

Comments

Instead of changing the title to "[SOLVED]" can you accept this answer? ROS Answers will then mark it as "answered" in the system.

jbohren gravatar imagejbohren ( 2012-10-08 10:02:15 -0500 )edit
1

I cannot accept the answer as I don't have 25 points. Looks like Kevin has closed the question for me.

durka42 gravatar imagedurka42 ( 2012-10-08 18:27:22 -0500 )edit

How about now (:

jbohren gravatar imagejbohren ( 2012-10-08 18:30:47 -0500 )edit

Question Tools

Stats

Asked: 2012-10-06 11:49:02 -0500

Seen: 179 times

Last updated: Oct 08 '12