Ask Your Question
0

Ros install 10.6.8 make -j8 problem undefined symbols

asked 2012-09-25 04:19:54 -0500

heyfred gravatar image

updated 2012-09-25 11:02:45 -0500

Kevin gravatar image

Still trying to run the command:

make -j8

on Mac OS-X SnowLeopard (10.6.8)

When i do I get this problem

Macbook:build **********$ make -j8
    ...
        [ 61%] Built target turtle_teleop_key
        [ 61%] Built target mimic
        [ 61%] Built target relay
        [ 61%] [ 61%] [ 61%] Built target throttle
        Built target rosbag
        Built target switch_mux
        [ 61%] Built target turtlesim_node
        [ 61%] Built target play
        [ 61%] Built target record
        Linking CXX shared library ../../lib/librxtools.dylib
        ld: warning: in /System/Library/Frameworks//QuickTime.framework/QuickTime, missing required architecture x86_64 in file
        ld: warning: in /usr/lib/libwx_macud-2.8.dylib, missing required architecture x86_64 in file
        ld: warning: duplicate dylib /usr/local/lib/libboost_signals-mt.dylib
        ld: warning: duplicate dylib /usr/local/lib/libboost_regex-mt.dylib
        ld: warning: duplicate dylib /usr/local/lib/libboost_thread-mt.dylib
        Undefined symbols:
          "wxGetTopLevelParent(wxWindow*)", referenced from:
              wxTopLevelWindowBase::IsActive()      in topic_display_generated.cpp.o
              wxTopLevelWindowBase::IsActive()      in topic_display_dialog.cpp.o
              wxTopLevelWindowBase::IsActive()      in rosout_generated.cpp.o
              wxTopLevelWindowBase::IsActive()      in rosout_setup_dialog.cpp.o
          "vtable for wxwxColumnListNode", referenced from:
              wxwxColumnListNode::wxwxColumnListNode(wxListBase*, wxwxColumnListNode*, wxwxColumnListNode*, wxListItem*, wxListKey const&)in rosout_list_control.cpp.o
...
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[2]: *** [lib/librxtools.dylib] Error 1
make[1]: *** [rx/rxtools/CMakeFiles/rxtools.dir/all] Error 2
make: *** [all] Error 2

Does anybody have any idea of what to do to fix this problem?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-09-26 09:54:02 -0500

WilliamWoodall gravatar image

updated 2012-09-26 09:54:45 -0500

You get a warning from the linker:

ld: warning: in /usr/lib/libwx_macud-2.8.dylib, missing required architecture x86_64 in file

Which means that you are building 64-bit, but that library is not built for 64-bit. If that is the case it might contain the undefined symbols which appear later in the error message.

How did you install wxPython? The recommended method is using a binary from wxPython's website.

edit flag offensive delete link more

Comments

Yes that is how i installed it. I looked into the wxPython again and found I'd installed the 32bit version only because I had Python 2.6. I've now installed Python 2.7 and a new wxPython however when I run CMake it says: Unable to find either executable 'empy' or Python module 'em'...

heyfred gravatar image heyfred  ( 2012-09-27 02:01:26 -0500 )edit

You'll need to install empy (sudo pip install empy)

WilliamWoodall gravatar image WilliamWoodall  ( 2012-09-27 06:40:43 -0500 )edit
1

It was complaining about empy because it was installed in the Python2.6 folder instead of the python 2.7.

I've fixed that and I'm still getting the same problem. I also reinstalled wxPython from the link in the wiki page. Any other suggestions?

heyfred gravatar image heyfred  ( 2012-09-28 02:25:25 -0500 )edit
0

answered 2012-11-16 08:33:50 -0500

snooze_bear gravatar image

Did you figure out how to fix this problem? I'm having exactly the same error message as you. (Sorry I would post this as a comment but I don't have enough karma yet.)

edit flag offensive delete link more

Comments

No I gave up on it in the end as I couldn't make any progress on it.

heyfred gravatar image heyfred  ( 2012-11-25 02:07:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-09-25 04:19:54 -0500

Seen: 350 times

Last updated: Nov 16 '12