Ask Your Question
0

can't install ros-electric-openni-camera

asked 2012-09-24 23:26:57 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

when $sudo apt-get install ros-electric-openni-camera That's a error: E: Unable to locate package ros-electric-openni-camera how to fix this problem? thanks for any help!

I have runned the instructions from the installation page and I have built rgbdslam. So I am using Electric and not Fuerte. When came to the Usage: roslaunch rgbdslam kinect+rgbdslam.launch the error came, as followed: Cannot locate installation of package openni_camera: [rospack] couldn't find package [openni_camera]. ROS_ROOT[/opt/ros/electric/ros] ROS_PACKAGE_PATH[/home/sean/ros:/opt/ros/electric/stacks] So I thought I haven't installation the package openni_camera and I have tried to install it using "sudo apt-get install ros-electric-openni-camera ". However, the problem came! I haven't tried apt-get install ros-electric-openni-kinect. Can ros-electric-openni-kinect work? What's the different between them?

edit retag flag offensive close merge delete

Comments

2

Did you run the instructions from the installation page to set up your apt sources? Are you really using Electric and not Fuerte? Did you run apt-get update first? Have you tried apt-get install ros-electric-openni-kinect?

Thomas D gravatar image Thomas D  ( 2012-09-24 23:50:48 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-09-26 05:23:39 -0500

Thomas D gravatar image

In general, I think you may want to look at the differences between packages and nodes and how nodes are a subset of packages. I believe you are trying to run the openni_camera_deprecated node, and looking at that page it seems that node is deprecated, meaning it is no longer being developed. If you wanted to run that node then you would install the openni_kinect package. Since it is deprecated though, it is recommended that you use openni_launch and openni_camera in Electric and later. There is some ambiguity here, because when you go to the page for the recommended packages it says they are available for Fuerte and later.

The end result is that you should try to install the ros-electric-openni-kinect package with

sudo apt-get install ros-electric-openni-kinect

Then, try running with one of the provided launch files. Also, there is a lot of documentation that will help you get started on those pages above.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-24 23:26:57 -0500

Seen: 1,169 times

Last updated: Sep 26 '12