Ask Your Question
1

WARNING using viso2_ros mono_odometer: "The tf from '/base_link' to '/camera' does not seem to be available, will assume it as identity!"

asked 2012-09-20 03:48:10 -0500

aldo85ita gravatar image

Hi everybody, I can run mono_odometer application properly, but I continue to get the warning showed in the title. How to fix it? How can I set the tf from /base_link' to '/camera' ?

Kind regards. Aldo

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-09-20 03:52:50 -0500

dornhege gravatar image

Do you know the tf library? If not, read up on that.

You need to define a transform from /base_link to /camera, i.e. basically where it is mounted on the robot. If that is fixed, you can use a static_transform_publisher, otherwise define a URDF description.

edit flag offensive delete link more

Comments

I know how to create a tf object , but I don't know how to set it. In particularly, I don't know how to set base_link_frame_id tf of viso2ros.

aldo85ita gravatar imagealdo85ita ( 2012-09-20 05:18:53 -0500 )edit

Use a static_transform_publisher or create an urdf. You can also use a custom TransformBroadcaster if necessary.

dornhege gravatar imagedornhege ( 2012-09-20 05:44:27 -0500 )edit

ok, I've used roscd tf ./bin/static_transform_publisher 0 0 2 0.0 0.0 0.0 /base_link /camera 100

aldo85ita gravatar imagealdo85ita ( 2012-09-20 06:33:40 -0500 )edit

I'd advise to use rosrun. Also units are in meters, so 2 seems large (but might be correct)

dornhege gravatar imagedornhege ( 2012-09-20 06:53:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-20 03:48:10 -0500

Seen: 738 times

Last updated: Sep 20 '12