ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

installing ROS-Electric - not enough free space

asked 2012-09-18 21:03:05 -0600

agrirobot-George gravatar image

Hi everybody I am trying to install ROS-Electric on Ubuntu 11.10 (Onereic). I follow the instructions provided at the ROS download site but when I type the command :~$ sudo apt-get install ros-electric-desktop-full

I get the following message at the end.

7 upgraded, 381 newly installed, 0 to remove and 391 not upgraded. Need to get 1,071 MB of archives. After this operation, 2,824 MB of additional disk space will be used.

E: You don't have enough free space in /var/cache/apt/archives/.

I searched on ubuntu question/answers and at some point I found that I should use the command "sudo apt-get clean" to cleanup space in /var/cache/apt/archives. No luck, I still get the same message.

Can somebody help with this? Thank you all. George

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2012-09-18 22:23:33 -0600

Lorenz gravatar image

It seems like the partition /var is mounted on. It is likely that you will not have enough space for extracting ros either Maybe you can increase it using something like gparted or create separate partitions for /var and /opt.

edit flag offensive delete link more

answered 2012-09-18 22:26:27 -0600

Jakub gravatar image

Try the command:

# df -h

and check the size of the partition you have allocated for /var

edit flag offensive delete link more

answered 2012-09-18 23:36:56 -0600

agrirobot-George gravatar image

updated 2012-09-18 23:41:22 -0600

When I run df -h I get this

Filesystem            Size  Used Avail Use% Mounted on
/dev/sda6             3.4G  2.6G  630M  81% /
udev                  2.0G  4.0K  2.0G   1% /dev
tmpfs                 793M  784K  793M   1% /run
none                  5.0M     0  5.0M   0% /run/lock
none                  2.0G  124K  2.0G   1% /run/shm
edit flag offensive delete link more



Please do not create new ansers for discussions. This is not like a normal forum. Instead please edit your original post or use the comment functionality. Btw. the informaton means that your root partition is too small. You simply do not have enough space left on your hard drive.

Lorenz gravatar image Lorenz  ( 2012-09-18 23:42:54 -0600 )edit

Yes, Lorenz is right. Not enough space on root. Standard ROS installation is about 400 MB, that first have to downloaded in packages, and later installed in the system. So you need around 800 MB of free space, at least during installation.

Jakub gravatar image Jakub  ( 2012-09-19 02:07:07 -0600 )edit

Thank you all. Problem solved then!

agrirobot-George gravatar image agrirobot-George  ( 2012-09-20 04:25:51 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2012-09-18 21:03:05 -0600

Seen: 1,047 times

Last updated: Sep 18 '12