Ask Your Question
1

ros-pcl libraries don't work on my cpu?

asked 2012-09-18 01:58:24 -0500

robert_81 gravatar image

updated 2012-09-18 03:02:13 -0500

Hi!

I have the following error everytime i use something related to the PCL: illegal instruction (core dumped)

E.g. i execute voxel_grid table_scene_lms400.pcd test.pcd, or pcd_viewer table_scene_lms400.pcd, and i get the error "illegal instruction".

gdb output (for voxel_grid):

0x00007ffff740b769 in pcl::VoxelGrid<sensor_msgs::PointCloud2_<std::allocator<void> > >::applyFilter(sensor_msgs::PointCloud2_<std::allocator<void> >&) () from /opt/ros/fuerte/lib/libpcl_filters.so.1.5

gdb output (for pcd_viewer):

0x00007ffff74886a5 in pcl::visualization::PointCloudColorHandlerRandom<sensor_msgs::PointCloud2_<std::allocator<void> > >::getColor(vtkSmartPointer<vtkDataArray>&) const () from /opt/ros/fuerte/lib/libpcl_visualization.so.1.5

I installed ubuntu 12.04 and ros on a new hard drive, but if i plug the drive into another PC, the error don't occure.

My CPU is: Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz (flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm lahf_lm dtherm tpr_shadow vnmi flexpriority)

My system: 64bit ubuntu 12.04

Is it possible, that some flags are used for the precompiled ros-binaries, which doesn't work with my cpu?

cheers Robert

edit retag flag offensive close merge delete

Comments

Hi again, perhaps i was not clear with my description: I used here both binaries of the deb-packages (voxel_grid and pcd_viewer), it doesn't work on one PC, but when i take the hard-disk and put it into another PC (with another cpu), it works!? i think the binaries are not compatible with my CPU?

robert_81 gravatar image robert_81  ( 2012-09-18 21:43:57 -0500 )edit

I'm having the same issue, code that runs fine on one machine crashes with illegal instruction on another (in this case an Intel i7 vs AMD Phenom II). Voxel grid does again seem to be the culprit.

markpitchless gravatar image markpitchless  ( 2012-11-21 02:17:44 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-09-18 03:24:50 -0500

allenh1 gravatar image

The issue comes from your use of sensor_msgs::PointCloud2 inside the voxelgrid. It appears to only take a point. Try just a pcl::PointXYZ and run it.

edit flag offensive delete link more

Comments

The example on the PCL site uses sensor_msgs::PointCloud2! I have voxel grid code that runs ok on one machine with either type (PointXYZ, PointXYZRGB, PointCloud2) but throws Illegal Instruction on another machine with either type.

markpitchless gravatar image markpitchless  ( 2012-11-21 02:20:17 -0500 )edit
0

answered 2012-12-12 09:38:38 -0500

Subhasis gravatar image

Hi,

I am facing the same issue. It works on an intel Machine and is failing on my AMD 64 bit machine. When i try to execute below line of code, I get illegal instruction (core dumped).

  if(!viewer->wasStopped())
        {
        viewer->showCloud(m_pointCloudPtr);
        }

It would be very helpful if someone can put some light into this issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

4 followers

Stats

Asked: 2012-09-18 01:58:24 -0500

Seen: 544 times

Last updated: Dec 12 '12