Ask Your Question
3

Boost error when building Fuerte on OS X mountain lion (10.8.1)

asked 2012-09-10 23:38:42 -0500

tropic gravatar image

updated 2012-09-14 08:36:04 -0500

Kevin gravatar image

I am trying to install ROS Fuerte on Mac OS X mountain lion (10.8.1) as per the guide. When I make ros-underlay/build I get this error. I tried to revert to boost 1.49.0 instead since some have had success with this, but it did not help.

Anyone got an idea how to solve this issue?

[  3%] Built target std_msgs_gencpp
[  6%] Built target std_msgs_genlisp
[ 10%] Built target std_msgs_genpy
[ 11%] Built target rospack
[ 11%] Built target rospackexe
[ 11%] Built target rosstackexe
[ 11%] Built target roslib
[ 11%] Built target cpp_common
Linking CXX shared library ../../lib/librostime.dylib
Undefined symbols for architecture x86_64:
  "boost::system::system_category()", referenced from:
      ___cxx_global_var_init3 in time.cpp.o
      boost::thread_exception::thread_exception(int, char const*) in time.cpp.o
  "boost::system::generic_category()", referenced from:
      ___cxx_global_var_init1 in time.cpp.o
      ___cxx_global_var_init2 in time.cpp.o
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[2]: *** [lib/librostime.dylib] Error 1
make[1]: *** [roscpp_core/rostime/CMakeFiles/rostime.dir/all] Error 2
make: *** [all] Error 2

Edit: So I got past this error by adding Williams pull request for rostime/CMakeLists.txt

find_package(Boost REQUIRED COMPONENTS date_time thread system)

Had to also install libtool, autoconf and automake, which was not mentioned in the guide. However, now I get a new error when doing brew install log4cxx

configure.in:338: the top level
configure.in:40: error: version mismatch.  This is Automake 1.12.3,
configure.in:40: but the definition used by this AM_INIT_AUTOMAKE
configure.in:40: comes from Automake 1.9.6.  You should recreate
configure.in:40: aclocal.m4 with aclocal and run automake again.

Edit2: brew --config returns

HOMEBREW_VERSION: 0.9.3
HEAD: f53ef3529c14f5848d7c51c6896ecdc4ba0750d7
HOMEBREW_PREFIX: /usr/local
HOMEBREW_CELLAR: /usr/local/Cellar
CPU: dual-core 64-bit penryn
OS X: 10.8.1-x86_64
Xcode: 4.4.1
CLT: 4.4.0.0.1.1249367152
LLVM-GCC: build 2336
Clang: 4.0 build 421
System Ruby: 1.8.7-358
Perl: /usr/bin/perl
Python: /usr/bin/python
Ruby: /usr/bin/ruby => /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby

Edit3: Wow got it working, except for a small error when doing rosdep install -a in the guide. Other than that, I can now run roscore etc. Will update later when I get a better overview of what I did to get it to work.

edit retag flag offensive close merge delete

Comments

Please add appropriate tags to your question to make sure the right people who might be able to help get notified.

Lorenz gravatar imageLorenz ( 2012-09-10 23:52:34 -0500 )edit

Updated to reflect my progress. I got past the boost error by adding Williams pull request. Also, I updated boost to 1.50.0 with no issues.

tropic gravatar imagetropic ( 2012-09-12 05:17:38 -0500 )edit

The log4cxx error looks brew specific. Have you checked the issue tracker for Homebrew on github.com to see if it has been reported? I am testing the log4cxx install on my machine right now.

WilliamWoodall gravatar imageWilliamWoodall ( 2012-09-12 06:48:03 -0500 )edit

log4cxx builds successfully on my machine. I do not have autoconf/automake/libtool installed and my xcode/clt version is 4.4.1

WilliamWoodall gravatar imageWilliamWoodall ( 2012-09-12 07:06:56 -0500 )edit

I do not see any open issues for log4cxx on the homebrew issue tracker. What version do you have installed? I also have xcode 4.4.1.

tropic gravatar imagetropic ( 2012-09-13 09:53:20 -0500 )edit

I removed autoconf/automake/libtool again with brew and now I get this again ./autogen.sh: line 23: glibtoolize: command not found ./autogen.sh: line 27: aclocal: command not found ./autogen.sh: line 28: autoconf: command not found ./autogen.sh: line 29: automake: command not found

tropic gravatar imagetropic ( 2012-09-13 09:55:01 -0500 )edit

What is the output of brew doctor? This might be something you need to raise on the Homebrew issue tracker. Make sure you review https://github.com/mxcl/homebrew/wiki/Bug-Fixing-Checklist before submitting a ticket to them.

WilliamWoodall gravatar imageWilliamWoodall ( 2012-09-13 09:55:36 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-09-11 05:06:49 -0500

This appears to be a duplicate of this question: http://answers.ros.org/question/43272/ros-install-problem-osx-1068/

There was a problem with a missing library dependency in rostime. It has been fixed, but not in the version that the OSX install guide instructions download. Try William's patch in the previous post.

edit flag offensive delete link more

Comments

Additionally, I'm not sure that any work on 10.8 has happened yet. It may be worth it to hold off on updating for a bit until homebrew and ROS catch up to the new release.

mjcarroll gravatar imagemjcarroll ( 2012-09-11 08:40:10 -0500 )edit

I don't know that it's officially supported and you might have better luck with Lion, but I'm running Fuerte on 10.8 right now without any major issues. I've passed along the issues I ran into to William, but I'm not sure that it has all been incorporated upstream or into the guide.

david.hodo gravatar imagedavid.hodo ( 2012-09-11 08:44:35 -0500 )edit

The patch in question has been merged and will be in the next release of roscpp_core.

WilliamWoodall gravatar imageWilliamWoodall ( 2012-09-11 08:53:49 -0500 )edit

The new version of roscpp_core has been released I believe.

WilliamWoodall gravatar imageWilliamWoodall ( 2012-09-11 17:53:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-09-10 23:38:42 -0500

Seen: 1,361 times

Last updated: Sep 14 '12