Ask Your Question
0

Broke my installation trying to install the pr2 packages.

asked 2012-09-08 06:07:35 -0500

andrew-unit gravatar image

Hello, I'm running Ubuntu 12.04, and I wanted to dust off a robot simulation that I have run in the past for a class:

https://code.google.com/p/hacdc-ros-pkg/source/browse/#svn%2Ftrunk%2Firobotron_description

The problem is that I hadn't run it since last year (on Electric) and when I try running it now I get errors related to the controller manager. So I tried installing the PR2 packages; I remembered needing to use the PR2 controller manager.

When I went to synaptic to install ros-fuerte-pr2, it told me it was going to uninstall ros-fuerte-desktop-full and a few other things. It seemed frightening but I went with it anyway.

Unfortunately that didn't help as I could no longer even run the gazebo_worlds empty_world.launch after that.

So, I decided to uninstall ROS fuerte altogether to start fresh by doing:

  1. sudo apt-get remove ros-fuerte-*
  2. sudo apt-get clean && sudo apt-get update
  3. sudo apt-get install ros-fuerte-desktop-full

However, when I try that, things are still broken. Here is the output from the last command:

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

ros-fuerte-desktop-full : Depends: ros-fuerte-simulator-gazebo (= 1.6.15-s1346871527~precise) but it is not going to be installed

E: Unable to correct problems, you have held broken packages.

I also tried doing "Fix broken packages" from synaptic but that didn't seem to help. My current plan is to reinstall 12.04 and install Fuerte again fresh. However if there is a way to fix this without doing that I'd appreciate any advice!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-09-08 06:17:18 -0500

Ryan gravatar image

This is similar to this issue and is due to this ticket (already fixed, packages are being rebuilt right now).

I suggest waiting a little bit for the rebuild before trying the nuclear option. :)

edit flag offensive delete link more

Comments

Thanks Ryan! I will do just that.

andrew-unit gravatar image andrew-unit  ( 2012-09-08 12:48:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-08 06:07:35 -0500

Seen: 192 times

Last updated: Sep 08 '12