Ask Your Question
0

p2os teleop

asked 2012-09-07 02:30:23 -0500

em gravatar image

Hi,

I'm using ros fuerte, pioneer 3dx robot and p2os(even though there's no version of p2os for ros fuerte, p2os works and i can publish cmd to robot - robot moves)..

so I need to use the joystick and to move robot manually. When I launch the teleop_joy.launch, it works well and it seems that connection is established, but pioneer doesn't move.

Since it didn't work, I've found this question http://answers.ros.org/question/39962/problem-with-p2os-teleop/ and did the remaping part in teleop_joy.launch:

remap from="/p2os_teleop/cmd_vel" to="/cmd_vel"

remap from="/p2os_teleop/joy" to ="/joy"

Again it didn't work. I also tried to include teleop_joy.launch in p2os.launch file, and again, connection is established and everyhing seems ok, but robot still dosen't move.. :/ when I call rxgraph function, I can see that cmd_vel is published from /p2os_teleop to /p2os driver.

any idea what else to do? thank you in advance for your help :)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-09-07 05:31:01 -0500

joq gravatar image

It usually helps to use rostopic echo or rostopic hz to confirm that data are actually being published on all your topics of interest.

edit flag offensive delete link more

Comments

I've checked that also, but didn't help - everything seemed fine.. One friend of mine helped me, the problem was with hardvare-the joystick wasn't compatible :/ anyway, it works now :)

em gravatar image em  ( 2012-09-11 11:50:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-07 02:30:23 -0500

Seen: 406 times

Last updated: Sep 07 '12