Ask Your Question
5

Ros install problem OSX 10.6.8

asked 2012-09-06 09:57:31 -0500

heyfred gravatar image

updated 2012-09-08 12:17:14 -0500

Kevin gravatar image

When trying to install rosjava using this link: http://www.ros.org/wiki/fuerte/Installation/OSX/Homebrew/Source

I get to the step where I run the command:

make -j8

This command fails with the following output:

[ 11%] [ 11%] Built target std_msgs_genpy
[ 11%] Built target std_msgs_gencpp
[ 11%] Built target cpp_common
[ 11%] Built target roscpp_serialization
Built target std_msgs_genlisp
Linking CXX shared library ../../lib/librostime.dylib
[ 11%] [ 11%] Built target xmlrpcpp
Built target rospack
[ 11%] Built target roscpp_gencpp
[ 11%] Undefined symbols:
  "boost::system::generic_category()", referenced from:
      __static_initialization_and_destruction_0(int, int)in time.cpp.o
      __static_initialization_and_destruction_0(int, int)in time.cpp.o
  "boost::system::system_category()", referenced from:
      boost::thread_exception::thread_exception(int, char const*)in time.cpp.o
      __static_initialization_and_destruction_0(int, int)in time.cpp.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[2]: *** [lib/librostime.dylib] Error 1
Built target topic_tools_genpy
[ 11%] [ 11%] Built target topic_tools_genlisp
[ 11%] Built target topic_tools_gencpp
[ 11%] make[1]: *** [roscpp_core/rostime/CMakeFiles/rostime.dir/all] Error 2
Built target test_rosservice_gencpp
make[1]: *** Waiting for unfinished jobs....
Built target roscpp_genpy
[ 11%] Built target roscpp_genlisp
make: *** [all] Error 2

Can anyone advise how I can fix this error? I am using osx 10.6.8 and the boost version thats installed is 1.49.0.

edit retag flag offensive close merge delete

Comments

1

I have seen this problem with boost 1.5.0, the problem is that boost_system is not being linked against. Can you confirm the boost version? You would need to modify the rostime CMakeLists.txt to include target_link_libraries(rostime boost_system)

WilliamWoodall gravatar image WilliamWoodall  ( 2012-09-06 11:39:02 -0500 )edit
1

I have confirmed that I am using boost 1.49.0 could you explain which CMakeLists.txt to edit?

heyfred gravatar image heyfred  ( 2012-09-07 01:33:59 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
3

answered 2012-09-06 11:43:14 -0500

WilliamWoodall gravatar image

updated 2012-09-10 11:19:29 -0500

I think this is a duplicate of:

http://answers.ros.org/question/42167/error-building-fuerte-on-osx/

I think this needs to be fixed upstream, but ensuring you are using boost 1.49 should fix the problem.

If you can confirm that you are not using boost 1.50 or something like that then it might be a different underlying problem.

EDIT: Try this patch (you can apply it manually or using git apply <patch>):

diff --git a/rostime/CMakeLists.txt b/rostime/CMakeLists.txt
index 26c46a6..471ca86 100644
--- a/rostime/CMakeLists.txt
+++ b/rostime/CMakeLists.txt
@@ -4,7 +4,7 @@ include_directories(include)

 find_package(cpp_common REQUIRED)
 include_directories(${cpp_common_INCLUDE_DIRS})
-find_package(Boost REQUIRED COMPONENTS date_time thread)
+find_package(Boost REQUIRED COMPONENTS date_time thread system)

 add_library(rostime 
   src/time.cpp src/rate.cpp src/duration.cpp)

This file is in the ros-underlay/roscpp_core/rostime/ folder.

EDIT: Pull request to fix this upstream

https://github.com/ros/roscpp_core/pull/5

edit flag offensive delete link more

Comments

1

I have confirmed that I am using Boost 1.49.0. I saw that post and removed boost 1.50.0 and then installed 1.49

When i run: brew install boost Error: boost-1.49.0 already installed

heyfred gravatar image heyfred  ( 2012-09-07 01:35:06 -0500 )edit
1

Ok, I'll see if I can reproduce the problem on my VM.

WilliamWoodall gravatar image WilliamWoodall  ( 2012-09-07 07:01:33 -0500 )edit
1

I applied the patch manually and it has fixed my problem. Thank you very much for this solution.

heyfred gravatar image heyfred  ( 2012-09-07 09:04:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-06 09:57:31 -0500

Seen: 761 times

Last updated: Sep 10 '12