Ask Your Question
1

cannot install at all (ubuntu 12.04 amd64)

asked 2012-09-06 00:50:42 -0500

Claudio gravatar image

So I've got a VM running Ubuntu 12.04.1 x86 on my laptop, and my desktop is running 12.04 amd64.

Installation on the VM went smooth. No way of getting ROS Fuerte to install on the desktop though.

I updated the sources as per the installation tutorial, but when I get to the actual installation there are all sorts of unmet dependencies.

 sudo apt-get install ros-fuerte-desktop-full
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-fuerte-desktop-full : Depends: ros-fuerte-nodelet-core (= 1.6.5-s1346187746~precise) but it is not going to be installed
                           Depends: ros-fuerte-geometry-tutorials (= 0.1.3-s1346209883~precise) but it is not going to be installed
                           Depends: ros-fuerte-orocos-kinematics-dynamics (= 0.2.3-s1346186954~precise) but it is not going to be installed
                           Depends: ros-fuerte-filters (= 1.6.0-s1346190801~precise) but it is not going to be installed
                           Depends: ros-fuerte-slam-gmapping (= 1.2.7-s1346196768~precise) but it is not going to be installed
                           Depends: ros-fuerte-simulator-gazebo (= 1.6.14-s1346200794~precise) but it is not going to be installed
                           Depends: ros-fuerte-visualization (= 1.8.14-s1346193234~precise) but it is not going to be installed
                           Depends: ros-fuerte-vision-opencv (= 1.8.4-s1346232876~precise) but it is not going to be installed
                           Depends: ros-fuerte-perception-pcl (= 1.2.3-s1346187964~precise) but it is not going to be installed
                           Depends: ros-fuerte-geometry-experimental (= 0.2.3-s1346197152~precise) but it is not going to be installed
                           Depends: ros-fuerte-robot-model-visualization (= 0.1.2-s1346200453~precise) but it is not going to be installed
                           Depends: ros-fuerte-common-tutorials (= 0.2.3-s1346212230~precise) but it is not going to be installed
                           Depends: ros-fuerte-image-pipeline (= 1.8.4-s1346233129~precise) but it is not going to be installed
                           Depends: ros-fuerte-bfl (= 0.1.0-s1346191138~precise) but it is not going to be installed
                           Depends: ros-fuerte-diagnostics-monitors (= 1.4.3-s1346199496~precise) but it is not going to be installed
                           Depends: ros-fuerte-common-rosdeps (= 1.2.0-s1346186808~precise) but it is not going to be installed
                           Depends: ros-fuerte-geometry-visualization (= 0.1.1-s1346255820~precise) but it is not going to be installed
                           Depends: ros-fuerte-image-common (= 1.8.0-s1346187257~precise) but it is not going to be installed
                           Depends: ros-fuerte-bond-core (= 1.6.3-s1346187671~precise) but it is not going to be installed
                           Depends: ros-fuerte-python-qt-binding (= 0.1.7-s1346191935~precise) but it is not going to be installed
                           Depends: ros-fuerte-visualization-common (= 1.8.4-s1346192005~precise) but it is not going to be installed
                           Depends: ros-fuerte-physics-ode (= 1.8.0-s1346191674~precise) but it is not going to be installed
                           Depends: ros-fuerte-driver-common (= 1.4.0-s1346186749~precise) but it is not going to be installed
                           Depends: ros-fuerte-executive-smach (= 1.2.0-s1346197089~precise) but it is not going to be installed
                           Depends: ros-fuerte-stage (= 1.6.6-s1346208690~precise) but it is not going to be installed
                           Depends: ros-fuerte-dynamic-reconfigure (= 1.4.2-s1346186665~precise) but it is not going to be installed
                           Depends ...
(more)
edit retag flag offensive close merge delete

Comments

Somehow I can't see my own answer. Anyway: solution is to get rid of libboost 1.48. ROS requires 1.46 and it can't be installed onto 1.48.

Claudio gravatar image Claudio  ( 2012-09-06 02:04:49 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2012-09-06 01:35:20 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Problem solved: I was using libboost 1.48.

ROS requires (hardwired dependencies) libboost 1.46. So as apt-get was unable to resolve the conflict, it said it had unmet dependencies.

Solution: remove all 1.48 libboost packages, install ROS.

edit flag offensive delete link more

Comments

Why are groovy and hydro debians for Ubuntu 12.4 not compiled against boost 1.48? Ubuntu 12.4 comes both with boost 1.46 & 1.48, but 1.46 has some problems with c++11

Daniel Pinyol gravatar image Daniel Pinyol  ( 2013-05-15 05:41:20 -0500 )edit
0

answered 2012-09-06 18:01:45 -0500

isao gravatar image

x86 has the same problem...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-06 00:50:42 -0500

Seen: 975 times

Last updated: Sep 06 '12