Segmentation fault on running rxconsole [closed]

asked 2012-08-28 23:34:42 -0500

Soda gravatar image

updated 2012-08-29 08:41:41 -0500

I'am trying to run rxconsole in this tutorial ttp://

When I run rxconsole command, I get a message "Segmentation fault (core dumped)".

I'm using Fuerte.

roscore Result:

kitsadapon@kitsadapon-Joybook-S42:~$ roscore
... logging to /home/kitsadapon/.ros/log/94e99e38-f1c1-11e1-aab5-00216a1612d4/roslaunch-kitsadapon-Joybook-S42-10854.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://kitsadapon-Joybook-S42:56657/
ros_comm version 1.8.10


 * /rosdistro
 * /rosversion


auto-starting new master
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[master]: started with pid [10870]

setting /run_id to 94e99e38-f1c1-11e1-aab5-00216a1612d4
Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored
process[rosout-1]: started with pid [10883]
started core service [/rosout]

The command I use to run rxconsole following this:

  • new terminal window

$ rosdep install rxtools turtlesim

$ rosmake rxtools turtlesim

  • new terminal window

$ roscore

  • new terminal window

$ rxconsole

segmentation fault (core dump)


edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2012-10-30 16:48:24


Need some more info around how it's been run, environment details etc

MarkyMark2012 gravatar image MarkyMark2012  ( 2012-08-28 23:36:48 -0500 )edit

I'm following this >roscore new terminal >rxconsole

Soda gravatar image Soda  ( 2012-08-28 23:58:06 -0500 )edit

Okay to roscore looks to be starting up okay. What are you getting in the rxconsole terminal when is crashes?

MarkyMark2012 gravatar image MarkyMark2012  ( 2012-08-29 04:51:52 -0500 )edit

Thank You for all answers. I've tried 2 times about my configuring of ROS Environment and ROS Workspace and I've found my mistake about Overlays with rosws procedure. Now I can do it.

Soda gravatar image Soda  ( 2012-08-29 11:25:32 -0500 )edit

In the "roscore" terminal - spawn roscore with "roscore &" then once it's started type, in the same terminal "rxconsole" - wondering if your environment might be a but shakey

MarkyMark2012 gravatar image MarkyMark2012  ( 2012-08-29 21:09:15 -0500 )edit