Ask Your Question
0

How to solve rosmake failed 'c++: internal compiler error' of rgbdslam?

asked 2012-08-25 21:24:00 -0500

sam gravatar image

updated 2014-01-28 17:13:27 -0500

ngrennan gravatar image

I followed rgbdslam.

I try to rosmake on ROS fuerte of rgbdslam

I run:

  svn co http://alufr-ros-pkg.googlecode.com/svn/trunk/rgbdslam_freiburg/rgbdslam
  svn co https://code.ros.org/svn/ros-pkg/stacks/vslam/trunk/g2o
  sed 's/depend package="eigen"/rosdep name="eigen"/g' rgbdslam/manifest.xml > rgbdslam/manifest.xml.bak; mv rgbdslam/manifest.xml.bak rgbdslam/manifest.xml
  sed 's/find_package(Eigen)/find_package(Eigen REQUIRED)/g' rgbdslam/CMakeLists.txt > rgbdslam/CMakeLists.txt.bak; mv rgbdslam/CMakeLists.txt.bak rgbdslam/CMakeLists.txt

When I rosmake, it shows:

  sam@sam:~/code/ros/slam/rgbdslam$ rosmake
  [ rosmake ] rosmake starting...                                                 
  [ rosmake ] No package specified.  Building ['rgbdslam']                        
  [ rosmake ] Packages requested are: ['rgbdslam']                                
  [ rosmake ] Logging to directory /home/sam/.ros/rosmake/rosmake_output-20120825-152734
  [ rosmake ] Expanded args ['rgbdslam'] to:
  ['rgbdslam']                         
  [rosmake-0] Starting >>> bullet [ make ]                                        
  [rosmake-0] Finished <<< bullet ROS_NOBUILD in package bullet                   
  [rosmake-0] Starting >>> geometry_msgs [ make ]                                 
  [rosmake-0] Finished <<< geometry_msgs  No Makefile in package geometry_msgs    
  [rosmake-0] Starting >>> sensor_msgs [ make ]                                   
  [rosmake-0] Finished <<< sensor_msgs  No Makefile in package sensor_msgs        
  [rosmake-0] Starting >>> roslang [ make ]                                       
  [rosmake-0] Finished <<< roslang  No Makefile in package roslang                
  [rosmake-0] Starting >>> roscpp [ make ]                                        
  [rosmake-0] Finished <<< roscpp  No Makefile in package roscpp                  
  [rosmake-0] Starting >>> rosconsole [ make ]                                    
  [rosmake-0] Finished <<< rosconsole  No Makefile in package rosconsole          
  [rosmake-0] Starting >>> angles [ make ]                                        
  [rosmake-0] Finished <<< angles ROS_NOBUILD in package angles                   
  [rosmake-0] Starting >>> rospy [ make ]                                         
  [rosmake-0] Finished <<< rospy  No Makefile in package rospy                    
  [rosmake-0] Starting >>> rostest [ make ]                                       
  [rosmake-0] Finished <<< rostest  No Makefile in package rostest                
  [rosmake-0] Starting >>> roswtf [ make ]                                        
  [rosmake-0] Finished <<< roswtf  No Makefile in package roswtf                  
  [rosmake-0] Starting >>> message_filters [ make ]                               
  [rosmake-0] Finished <<< message_filters  No Makefile in package message_filters
  [rosmake-0] Starting >>> tf [ make ]                                            
  [rosmake-0] Finished <<< tf ROS_NOBUILD in package tf                           
  [rosmake-0] Starting >>> g2o [ make ]                                           
  [ rosmake ] Last 40 lineso: 627.8 sec ]              [ 1 Active 12/32 Complete ]
  {-------------------------------------------------------------------------------
    [ 13%] Built target test_slam_interface
    make[3]: Entering directory `/home/sam/code/ros/slam/g2o/build/g2o/build'
    make[3]: Leaving directory `/home/sam/code/ros/slam/g2o/build/g2o/build'
    [ 23%] Built target stuff
    make[3]: Entering directory `/home/sam/code/ros/slam/g2o/build/g2o/build'
    make[3]: Leaving directory `/home/sam/code/ros/slam/g2o/build/g2o/build'
    [ 41%] Built target core
    make[3]: Entering directory `/home/sam/code/ros/slam/g2o/build/g2o/build'
    make[3]: Leaving directory `/home/sam/code/ros/slam/g2o/build/g2o/build'
    [ 45%] Built target g2o_cli_library
    make[3]: Entering directory `/home/sam/code/ros/slam/g2o/build/g2o/build'
    make[3]: Leaving directory `/home/sam/code/ros/slam/g2o/build/g2o/build'
    [ 47%] Built target g2o_cli_application
    make[3]: Entering directory `/home/sam/code/ros/slam/g2o/build/g2o/build'
    make[3]: Leaving directory `/home/sam/code/ros/slam/g2o/build/g2o/build'
    [ 48%] Built target solver_cholmod
    make[3]: Entering directory `/home/sam/code/ros/slam/g2o/build/g2o/build'
    make[3]: Leaving directory `/home/sam/code/ros/slam/g2o/build/g2o/build'
    [ 61%] Built target types_slam2d
    make[3]: Entering directory `/home/sam/code/ros/slam/g2o/build/g2o/build'
    make[3]: Leaving directory `/home/sam/code/ros/slam/g2o/build/g2o/build'
    [ 63%] Built target math_groups
    make[3]: Entering directory `/home ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-08-26 05:30:10 -0500

Hi there,

This is an error that I have seen in relation to the availability of lesser RAM or swap space. The discussion in the following link may help: GNU gcc Bugzilla

Further, I would recommend you to update your gcc to the latest version which could be a possible cause for this problem. You may check the version of your gcc using

gcc --version

Currently it is 4.6.x

The above solutions are general ones that may sometimes solve the error that you have got.

I hope this helps you to get started to resolve your issue. Update your question after having tried the above methods if your error still does not disappear.

All the best, Regards,

edit flag offensive delete link more

Comments

My gcc version is already 4.6.1, and I haven't tried to update gcc version. I have revised my original post. What to do next? Thank you~

sam gravatar image sam  ( 2012-08-28 23:26:05 -0500 )edit

As @SivamPillai said, try more RAM or a bigger swap partition.

Lorenz gravatar image Lorenz  ( 2012-08-29 01:12:25 -0500 )edit

How to extend swap partition? Which size is enough? Thank you~

sam gravatar image sam  ( 2012-09-02 21:36:52 -0500 )edit
1

That's not a ros-related question. I think it's best if you google for it. You will find plenty of information on how to resize. I suggest to make it at leat 4gb big, depending on the ram you have.

Lorenz gravatar image Lorenz  ( 2012-09-02 22:08:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-08-25 21:24:00 -0500

Seen: 1,264 times

Last updated: Aug 28 '12