Ask Your Question
1

Cannot launch most of the virtual environments from gazebo_world

asked 2012-08-21 23:23:54 -0500

Albert K gravatar image

updated 2012-08-23 22:09:24 -0500

I was trying to run a simulation in a virtual environment on gazebo. Therefore I launch the virtual environment in gazebo_worlds such as office_world.launch. The following error message occurred:

Msg Waiting for master[ INFO] [1345626416.332008069]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...

Msg Connected to gazebo master @ http://localhost:11345
[ INFO] [1345626419.675247663, 0.107000000]: waitForService: Service [/gazebo/set_physics_properties] is now available.
[ INFO] [1345626419.713744662, 2.769000000]: Starting to spin physics dynamic reconfigure node...

and gazebo window didn't occur

and I tried to launch empty_world.launch, it succeeded. Other launch file such as simple_office2.launch, simple_world.launch, wg_world.launch... failed, too.

How can I solve this problem or is there any other launch file that provides a complete virtual environment for simulation?

BTW I run Fuerte on Ubuntu 12.04

---------------------------------edit-------------------------------------

When I tried to launch simple_office2.launch, I got the following error:

Segmentation fault (core dumped)
[gazebo-2] process has died [pid 6666, exit code 139, cmd /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/scripts/gazebo /opt/ros/fuerte/stacks/simulator_gazebo/gazebo_worlds/worlds/simple_office2.world __name:=gazebo __log:=/home/albert/.ros/log/99159028-edc2-11e1-b88b-5404a6dc3a5e/gazebo-2.log].
log file: /home/albert/.ros/log/99159028-edc2-11e1-b88b-5404a6dc3a5e/gazebo-2*.log

I've added a new line in the launch file

<node name="gazebo_gui" pkg="gazebo" type="gui" respawn="false" output="screen"/>
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-08-23 06:37:06 -0500

seth_g gravatar image

make sure the following line is in the launch file

<node name="gazebo_gui" pkg="gazebo" type="gui" respawn="false" output="screen"/>
edit flag offensive delete link more

Comments

Thanks for the help. I could launch office_world.launch successfully. Buit while I tried to apply to other failed launch file, there were still some launch files that had error. I've post the new problem.

Albert K gravatar image Albert K  ( 2012-08-23 21:58:45 -0500 )edit

simple_office2 crashes for me as well. after digging I found it has something to do with the <body:map> world tags. the other world files that include the <body:map> tags have them commented out. unless you really want to use that world file, I wouldn't worry about it. you could always report a bug?

seth_g gravatar image seth_g  ( 2012-08-24 05:06:52 -0500 )edit

Do you have any idea about the <body:map> tag? As you say, there isn't such tag in other world file. I wonder if it is the reason that when I open rviz, the global fixed frame can't find "/map" and reports status error. Just a wild guess.

Albert K gravatar image Albert K  ( 2012-08-26 17:30:47 -0500 )edit

It's my understanding that it is a tag used to describe a map model within Gazebo. I haven't tried to use it nor have I explored the API for it, sorry. as for your fixed frame, I can't really say why it reports with an error. you might try /base_link instead of /map?

seth_g gravatar image seth_g  ( 2012-09-11 12:10:40 -0500 )edit
0

answered 2012-09-11 12:26:19 -0500

hsu gravatar image

Some of the worlds in gazebo_worlds were fixed as of simulator_gazebo 1.6.14. Please update your installs and check if the error has gone away. If not, please review this short troubleshooting page and post additional information on your issue?

thanks.

edit flag offensive delete link more

Comments

I'm seeing this issue on Groovy. Ticket opened https://code.ros.org/trac/ros-pkg/ticket/5594

130s gravatar image 130s  ( 2012-12-29 19:55:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-08-21 23:23:54 -0500

Seen: 807 times

Last updated: Sep 11 '12