ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

I'm running ros and qt at the same time, there is no error in the compilation part. But when running it gives an error

asked 2022-12-26 05:37:22 -0500

passwd gravatar image

updated 2022-12-26 05:40:36 -0500

OS : Windows 10 ROS : foxy QT : 5.15.2

I tried to put ROS2 and QT in the same project and I did it in ubuntu OS. but when i switch this system to windows side i got errors I did the steps on the official page to install ROS windows, but it keeps giving an error. While running talker and listener it doesn't give an error, but when I build my own package colcon it gives an error. When I run the package using ros2 run, I don't get an error, but when I run the .exe extension it created in the buil section, I get the error in the picture. When I compile the code with Qt, I still don't get an error, but when I run the file, I get an error.image description

Microsoft Visual C++ Runtime Library Debug Error!

...... talker.exe abort() has been called (press return to debug the application)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-12-26 23:25:24 -0500

passwd gravatar image

updated 2022-12-27 02:55:01 -0500

I think I understand the cause of the error. The file created when compiling with colcon build is created in the Release folder. occurs in debug folder when I compile with cmake. There are two files in the Debug folder, the first is exe and the second is pdb extension. How can I make it compile with cmake? Guess if I do this the problem will be solved

I converted the Debug folder to Release, for this I entered the following codes and the exe form worked cmake .. cmake --build . --config Release

edit flag offensive delete link more

Question Tools

Stats

Asked: 2022-12-26 05:37:22 -0500

Seen: 105 times

Last updated: Dec 27 '22