Ask Your Question
0

pr2_controller_manager [closed]

asked 2012-08-08 21:46:45 -0500

ZdenekM gravatar image

updated 2014-04-20 14:09:46 -0500

ngrennan gravatar image

Hi all,

I would like to play with pr2_manager_controller, but I found strange behaviour. I tried to start some controllers but didn't succeeded, so I tried most basic thing and found that - if I start just roscore and then use "rosrun pr2_controller_manager pr2_controller_manager list-types" it hangs and never produce any output. What might be wrong?

Ubuntu 11.10, ROS Electric (up-to-date).

edit retag flag offensive reopen merge delete

Closed for the following reason question is off-topic or not relevant. Please see http://wiki.ros.org/Support for more details. by ZdenekM
close date 2012-08-16 01:24:25

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-08-08 23:47:45 -0500

Lorenz gravatar image

The controller manager is probably not running.

pr2_controller_manager is just a library that provides a few services and the infra structure for running controller plugins in a loop. Gazebo or the real hardware (package pr2_etherCAT) link against that library and provide the interface between the controllers and the hardware.

If you just want to play around with pr2_controller_manager, run the PR2 in simulation with:

roslaunch pr2_gazebo pr2_empty_world.launch
edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-08-08 21:46:45 -0500

Seen: 177 times

Last updated: Aug 08 '12