ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

name 'xacro' is not defined

asked 2022-11-04 10:07:56 -0500

sergej gravatar image


when I'm trying to launch my simulation I get an error and when I execute the command in the error message I get the following output:

name 'xacro' is not defined 
when evaluating expression 'xacro.load_yaml(visual_parameters_file)' 
when evaluating expression 'config_visual_parameters['mesh_files']'
when instantiating macro: read_model_data 
 instantiated from: ur_robot (/root/ur_driver/install/ur_description/share/ur_description/urdf/ur_macro.xacro)
 in file: /root/ur_driver/install/ur_description/share/ur_description/urdf/ur.urdf.xacro

Yesterday it worked fine. I tried to rebuild the docker container and tried to reinstall xacro with

apt-get remove ros-foxy-xacro
apt-get install ros-foxy-xacro

I'm currently developing in a docker container with ubuntu 20.04 and ROS foxy. I'm working with the UR ROS2 Driver foxy branch and try to launch with the following command:

ros2 launch ur_bringup ur_type:=ur5e robot_ip:=yyy.yyy.yyy.yyy use_fake_hardware:=true launch_rviz:=false
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2022-11-11 06:22:25 -0500

sergej gravatar image

It was a problem with a new driver update of the UR ROS2 Drivers Description. I fixed it by getting an older version.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2022-11-04 10:07:56 -0500

Seen: 516 times

Last updated: Nov 11 '22