Ask Your Question
0

rosinstall hack to use http:// instead of git://

asked 2012-08-05 02:27:48 -0500

brainwave gravatar image

I am currently connected to my institute's network, which is causing git clone to fail. But rosinstall tries to get packages with only git clone git://

Where should i change the default protocol to http:// instead of git://

Also, when i tried changing .rosisntall file for configuring it to use http instead of git, it over wrote the thing.

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
2

answered 2012-08-05 13:59:14 -0500

PerkinsJames gravatar image

updated 2012-08-05 14:00:17 -0500

Download the rosinstall file:

wget http://ros.org/rosinstalls/fuerte-ros-full.rosinstall

then replace all instances of "git://" with "https://" (http may work also), but do not replace the lines that say "- git".

Then when you go to install, use the local file:

rosinstall --catkin ~/ros-underlay ./fuerte-ros-full.rosinstall

This is how I have to install also

edit flag offensive delete link more
3

answered 2012-08-05 22:51:48 -0500

KruseT gravatar image

If the git protocoll/port is blocked in your network (and only then), you could try following this answer: http://stackoverflow.com/questions/4891527/git-protocol-blocked-by-company-how-can-i-get-around-that

You could try this command:

git config --global url."http://".insteadOf git://

Which should add to your ~/.gitconfig:

[url "https://"]
   insteadOf = git://

However, this can also get you into trouble if you try to clone from a server that e.g. only offers git:// and https:// (not http://), so this is not a clean solution, but might still be okay for you.

If later you find out this causes more problems than it solves, just remove the added lines from your ~/.gitconfig

edit flag offensive delete link more

Comments

1

Ah, very nice. I didn't know how to do this without a hack.

PerkinsJames gravatar image PerkinsJames  ( 2012-08-06 07:05:20 -0500 )edit
2

answered 2012-08-05 12:25:32 -0500

KruseT gravatar image

The .rosinstall file is normally where you would change the url. The rosinstall command only overwrites the file if you call rosinstall with further arguments.

Maybe try using rosws instead:

http://www.ros.org/wiki/rosws

It could be easier to use.

edit flag offensive delete link more
1

answered 2012-08-05 04:37:28 -0500

joq gravatar image

rosinstall should use whatever URL you gave it, with whatever scheme.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-08-05 02:27:48 -0500

Seen: 1,965 times

Last updated: Aug 05 '12