rViz not loading the mesh .dae file

asked 2022-08-18 19:07:49 -0500

robot_commander gravatar image

updated 2022-08-18 20:06:27 -0500

Hi, I checked for this question in rosanswers and google and none of the previous answers solved my problem. I'm sure I'm missing something obvious here. I'm opening rViz and I'm trying to visualize my robot with the RobotModel plugin, and I get this error on rViz:

URDF Errors loading geometries: • for
link 'bucket': Could not load mesh

(I'm getting this error on all of the mesh files of this robot, so you might see different file names in this post)

And I get this error in the terminal running rViz:

[ERROR] [1660867019.412119678, 168.560000000]: Could not load resource [/home/<user_name>/catkin_ws/src/robot_sim/robot/meshes/stl/Mesh.040.stl]: Unable to open file "/home/<user_name>/catkin_ws/src/robot_sim/robot/meshes/stl/Mesh.040.stl".
  1. First thing I checked was whether that file exists in that location: and this is my output of the ls command:
ls -al `rospack find robot`/meshes/stl/Mesh.033.stl

and I see that this file exists. It has this permissions: -rw-rw-r-- 1

2. Next thing I checked was my URDF file: this is how it loads the file:

      <mesh filename="$(find robot)/meshes/stl/Mesh.005.stl" scale="1.0 1.0 1.0"/>

I tried changing this to accept the absolute path with /home/<user_name>/.., I also tried package:// prefix but I'm still getting this error.

Please help me fix this. Thank you.

edit retag flag offensive close merge delete


  1. I am wondering about the path you have reported /home/<user_name>/catkin_ws/
  2. Sometimes, if STL files are significantly large, say 100MB or more, RViz fails to load up. Though this is just my observation, the limit is found empirically.
ravijoshi gravatar image ravijoshi  ( 2022-08-18 21:41:01 -0500 )edit