Unknown control 'focus_auto' with usb_cam

asked 2022-07-18 18:04:37 -0500

chainley gravatar image

I'm working with my computer's camera and I'm trying to eliminate all of the warnings that I see when I start it up. So far, I've successfully calibrated it; however, I keep getting the following when I run the node:

$ rosrun usb_cam usb_cam_node _pixel_format:="yuyv" _autofocus:=1
[ INFO] [1658185040.189772004]: using default calibration URL
[ INFO] [1658185040.190590865]: camera calibration URL: file:///home/chainley/.ros/camera_info/head_camera.yaml
[ INFO] [1658185040.191144188]: Starting 'head_camera' (/dev/video0) at 640x480 via mmap (yuyv) at 30 FPS
[ WARN] [1658185040.507157226]: unknown control 'focus_auto' 

I've tried the command with 0 and 1 as the _autofocus setting. I've tried it without that option as well. Either way, I keep getting the unknown control warning.

Fortunately, the camera still publishes and I'm able to view that data with rqt_image_view, but the consistent warning each time I run it unnerves me. Any suggestions, explanations, or solutions are welcome!

edit retag flag offensive close merge delete